This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: Hi, I noticed big differences in loading speed of the same page with the base language and secondary languages. The secondary language pages take around the double of loading time. Try in GTmetrix or other tool.

Solution: Please deactivate the browser redirect function and let me know if the issue persists.

Also, please visit this link: https://wpml.org/faq/prevent-performance-issues-with-wpml/

Relevant Documentation:

Tagged: 

This topic contains 5 replies, has 2 voices.

Last updated by Carlos Rojas 3 months, 2 weeks ago.

Assigned support staff: Carlos Rojas.

Author Posts
July 3, 2019 at 10:24 am

marcoT-30

Hi, I noticed big differences in loading speed of the same page with the base language and secondary languages. The secondary language pages take around the double of loading time. Try in GTmetrix or other tool.

Base language (English)
hidden link

Italian
hidden link

Spain
hidden link

Thanks
Marco Todone

July 3, 2019 at 11:54 am #4135605

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

1.- I wasn't able to log in the site using the credentials provided. I have set your next answer private so you can provide new credentials in a secure way.

2.- Could you tell me if you are using the browser redirect option?

2.- Please increase the PHP Memory Limit. Minimum requirements are 128Mb: https://wpml.org/home/minimum-requirements/
You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '128M');
define( 'WP_MAX_MEMORY_LIMIT', '128M' );

- Add it above the line /* That's all, stop editing! Happy blogging. */

Kind regards,
Carlos

July 3, 2019 at 12:31 pm #4136293

marcoT-30

Hi Carlos, try now with this credentials:

hidden link
user: ****
pass: ****

I have increased the memory but nothing has changed. Yes, I use the browser redirect language.

Marco

July 3, 2019 at 1:00 pm #4136599

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you very much for your message.

Please deactivate the browser redirect function and let me know if the issue persists.

Note: I applied some troubleshooting steps that should improve the performance of the site. Please visit this link where you will find some recommendations: https://wpml.org/faq/prevent-performance-issues-with-wpml/

Regards,
Carlos

July 3, 2019 at 2:37 pm #4137493

marcoT-30

Thanks, now the things seems fine!

July 3, 2019 at 2:53 pm #4137675

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

I'm glad to hear that the issue is solved 🙂

Please don't hesitate to contact us if you need our help in the future with WPML. We will be more than happy to help.
Best regards,
Carlos