This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 18 replies, has 2 voices.

Last updated by Raja Mohammed 4 weeks ago.

Assigned support staff: Raja Mohammed.

Author Posts
April 4, 2019 at 7:18 am #3532793

antonD-13

Hi,

oon my site I can see circle in place of favicon, this cirle is still loading and not stopping. Also site loading is too slow and on mobile cant see the shop sections in foreign languages, only in the main language.

Many thanks for help.

April 4, 2019 at 7:29 am #3532827

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

Welcome to our forum,

I have checked your site, I don't see any favicon (check screenshot hidden link).

Can you please help me with the steps how you are adding the favicon to the site?

Kind regards
Raja

April 4, 2019 at 7:52 am #3532893

antonD-13

Hi,

thanks for prompt answer. The loading circle desapeard, maybe it was temporary issue. But second isste still preserve. The shop section right below the slider on homepage is not visible on mobile in other language, only in Slovak language.

Thanks.

April 4, 2019 at 12:58 pm #3535063

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

Seems the home page for translation is not displaying the products even in the desktop version of the site. Can you please provide me with the temporary access to your site. i have enabled private reply for you to securely share the details.

Kind regards
Raja

April 5, 2019 at 5:29 am #3540685

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

I am unable to access the site with the provided details, Can you please verify the login details and update the details in your previous private reply.

Kind regards
Raja

April 8, 2019 at 6:49 am #3554549

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

Thanks for the login, It seems like the shop module is not displaying for guest (not logged in) user, I have check with some basic troubleshooting steps seems like the issue needs to be isolated for a detailed investigation. To isolate the issue please install DIVI and Configure WPML to the test site ( WPML is already installed in the site)
hidden link

you will be directly logged in clicking on the above URL.

Please let me know once it is done.

Kind regards
Raja

April 8, 2019 at 3:06 pm #3559543

antonD-13

Hi there,

thanks for help. Divi is installed and activated.
Let me know if I can do anything else.

Thanks.

April 9, 2019 at 11:28 am #3566081

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

I am unable to reproduce the issue in a fresh install, This seems more like a plugin conflict with WPML.

Backup your site and database

I would suggest you please disable all Plugins except WPML + WooCommerce + WooCommere Multilingual. Check whether you can reproduce the issue. If the issue is sorted then try to activate the plugin once at a time and check for the conflicting plugin.

Please let me know the results.

In addition to the above mentioned debugging. It would be good if you can provide me with the WordPress debug.log (not WPML debug information).

To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

define('WP_DEBUG', true);
define( 'WP_DEBUG_LOG', true );

In this case, the errors will be saved to a debug.log log file inside the /wp-content/ directory.

If you can paste your debug.log to pastebin.com and provide me that link it would be great!

Kind regards
Raja

April 13, 2019 at 8:31 pm #3605617

antonD-13

Hi there,

I tried to deactivate all the plugins and activate them by one.
Problem is wit pugin "WooCommerce Wholesale Prices Premium" link to this plugin is: hidden link.

On their site I found that this plugin is WPML compatible. Can you help me to figure this out?

Thanks.

April 15, 2019 at 6:24 am #3609993

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

Thank you very much for trying the debugging steps, I can see that the plugin already has some known issues with wpml https://wpml.org/plugin/woocommerce-wholesale-prices-premium-2/

Please upload the plugin to the test install where you have already uploaded DIVI
=> hidden link
This will help me isolate the issue and escalate to our compatibility team.

In the meanwhile, you can also check with the plugin author if there is any known workaround from their side.

I highly appreciate your patience and cooperation.

Kind regards
Raja

April 17, 2019 at 6:12 am #3627421

antonD-13

Hi,

plugin is uploaded.

Thanks for help.

April 17, 2019 at 12:43 pm #3630799

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

Thanks for the update, I am unable to reproduce the issue with the plugin active,

May I request another favor from you, Please configure/ setup the "WooCommerce Wholesale Prices Premium" the same way as it is in your site it will help identify the exact conflicting factor with the plugin.

Let me know once done.

Kind regards
Raja

April 21, 2019 at 7:29 am #3651847

antonD-13

Hi,

I have setted the same settings as on may page in Wholesale plugin.

Thanks for helping.

April 22, 2019 at 12:52 pm #3655755

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

I am unable to reproduce the issue in the sandbox site with all the required settings, Please create a snapshot of the site You can use the Duplicator plugin to create a snapshot of the site and share the package link with me http://wordpress.org/plugins/duplicator/

I have enabled private fields for you to securely share the details.

Kind regards
Raja

April 24, 2019 at 5:22 am #3669311

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

It seems like the issue is not appearing anymore I can see the products in the shop module section in all languages in your site and also in the copy of your site. Can you please confirm the same?

Kind regards
Raja