This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 21 replies, has 2 voices.

Last updated by Riffaz 5 months, 3 weeks ago.

Assigned support staff: Riffaz.

Author Posts
April 9, 2019 at 1:34 pm #3567419

mariaA-26

Hi, I decided to let for both languages the same English logo, i's a practice that many websites follow.

But, I have a problem that didn't exist. In the mobile in English not in the home, in the others the header appears two times. Check it out. I attach the image.

It didn't appear in the past but after the tries for changing the logo. Can you fix it ?

April 9, 2019 at 2:06 pm #3567687

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for contacting WPML support.

I see the logo is duplicated in branding section : hidden link
Could you please revert what I suggested here ? https://wpml.org/forums/topic/i-cant-change-the-logo-between-the-languages/#post-3375983 then check the issue and let me know.

Regards,
Riffaz.

April 10, 2019 at 7:58 am #3573237

mariaA-26

Good morning,

I deleted the code from xml. And I tried to erase the translation in strings translation but nothing happens.

April 10, 2019 at 8:01 am #3573273

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Good morning.

I asked you to remove like this:
- From the wp-admin bar at the top, change the language
- Go to theme options -> Branding
- Delete the logo and see

April 10, 2019 at 8:50 am #3573659

mariaA-26

That's what is happening, its like it loads two times the header not only the logo.

April 10, 2019 at 8:52 am #3573715

mariaA-26

This is the image of the tablet screen

April 10, 2019 at 11:13 am #3575325

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

I escalated this to 2nd tier.

Please be patient till we get back to you.

Regards,

April 10, 2019 at 11:27 am #3575425

mariaA-26

Ok, thank you very much.

April 10, 2019 at 11:30 am #3575459

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

You are welcome.

** updating the status.

April 11, 2019 at 6:22 am #3584025

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Our team suspects that this should be compatibility issue or version conflict.
To make sure, we have to check this in a fresh installation.

Please:
1. go to hidden link
2. install your theme
3. configure the WPML as you have it in your site. at the last step (site key) just click next
4. set the logos as you as you have them in your site.
5. create only one post
6. create only one page

Are you seeing the same issue?
If yes, let us know how to check this.

Regards,

April 17, 2019 at 9:08 am #3628935

mariaA-26

Hi, I was away for a few days. I did what you told me. It seems that everything is working properly in the demo. So you can check i.

Thank you

April 18, 2019 at 1:27 pm #3639475

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for this.
So this is not an issue with demo.
This happen only on your site, right?

I am asking the second tier to check this in your site directly and using the login details you gave me.
Is that fine?

Regards,

April 19, 2019 at 7:41 am #3643893

mariaA-26

Yes it's fine by me.

Thank you

April 19, 2019 at 9:07 am #3644341

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you!
Already escalated to second tier support.

I will get back to you once I get something from them.

Regards,

April 22, 2019 at 7:24 am #3654097

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

For now use this workaround.

Go to WPML > languages > Language switcher options > additional css and add this code:

@media screen and (max-width: 767px){
.masthead:lang(en-US) .mobile-header-bar:nth-of-type(2) { display: none !important; }
}

hard clear your mobile cache and check.

If that does not work add the code to your theme css option panel and check.

I'll update you if there is any other way to this.

Regards,