This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by Mihai Apetrei 1 year ago.

Assigned support staff: Mihai Apetrei.

Author Posts
September 25, 2018 at 12:57 pm #2763845

austurki

hi
how are you today
i use valenti theme wich is compitable with wpml
how can i put to logos different depend on the anguage?
thanks in advance

September 25, 2018 at 7:54 pm #2765156

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hello and thank you for contacting WPML support!

I will be happy to help.

In general, you can try to do this (if logo is stored under wp_options table):

1. Go to WPML > String Translation
2. Open "Translate Texts on Admin Screens" (at the bottom of the page)
3. Then find the option where the theme stores its settings
4. Expand it, and see if there is Logo with the image link (logo_image)
5. Mark this and now go to the bottom of the page
6. Click apply and wait for the confirmation message
7. Now go to WPML String Translation and translate those strings

Please let me know if you are satisfied with my answer and if I can help you with any other questions you might have.

September 25, 2018 at 9:39 pm #2765303

austurki

i do that
and i found it
i apply
it is saved
but it doesent transfared to strings
it is not available there!!!

September 26, 2018 at 6:26 am #2765995

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

I see.

In order to take a look over the setup you are using I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. A testing site where the issue is replicated would also be helpful.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved, I will delete the local site.

Let me know if this is ok with you.

** IMPORTANT **

- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields, this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box.

The private box looks like this:
hidden link

September 26, 2018 at 8:33 am #2766470

austurki

hi
you wrote me
(((You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.)))

but i think you forget to add it
thanks

September 26, 2018 at 12:09 pm #2767134

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

Can you please check if the field shows up now?

September 26, 2018 at 2:09 pm #2767627

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

I found the fields we need to translate: "cb_logo_url" and "cb_logo_retina_url" (I am attaching a screenshot).

However, whenever I select them and click "Apply", even if they remain checked in the box, they still don't turn blue like the other ones neither they appear in the "String Translation" Page.

This can be caused by multiple reasons.

I will list below a few things I will need you to try that might solve the situation.

❌ Before proceeding please make a full website backup! ❌

1. Your WPML plugins are very old and need to be updated to the last version. Please update them all and then try to go again to the "Translate Texts on Admin Screens" section and follow the other steps in my older message.

2. Go to SG Optimizer > SuperCacher config > Purge the cache + disable Dynamic Caching. After doing this, also disable the "SG Optimizer" plugin and retry the steps above.

Let me know how it goes.

September 27, 2018 at 9:00 am #2769841

austurki

i do every thing in this steps
i deactivate the theme
and all plugins

still the problem available
is there other way to solve it like in database?

September 27, 2018 at 4:53 pm #2771335

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

If the strings still do not get added to the String Translation table, there's one more thing I would need you to do.

Please try increasing your Max Input Vars. You can do this by adding this line to your .htaccess file:

php_value max_input_vars 12000

or by following these steps:

1. Connect to your site via FTP or File Manager
2. Navigate to wp-admin folder
3. Create a file inside wp-admin folder called php.ini
4. Add in this line: max_input_vars = 12000
5. Save

If you don't have access to these files, please ask your hosting provider to do this for you.

Please let me know if you need any further assistance and I will be happy to help.