This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: Norebro theme not synchronizing theme settings Solution: If you notice that Norebro theme is not synchronizing settings between languages, change the language in the WordPress dashboard and update theme settings in the other language manually.

Tagged: 

This topic contains 12 replies, has 3 voices.

Last updated by emmanuelF-6 3 months, 1 week ago.

Assigned support staff: Bruno Kos.

Author Posts
June 14, 2019 at 6:09 pm

emmanuelF-6

I am using WPML to translate in English and French my website hidden link
Logo disappeared with WPML plugin for FRENCH language (all ok for ENGLISH language)
I deactivated the plugin, the logo is displayed perfectly.

Link to a page where the issue can be seen:
hidden link

I expected to see: LOGO

Instead, I got: TEXT and one navigation item ("Accueil")

My logo is hidden link

June 14, 2019 at 7:25 pm
June 14, 2019 at 7:33 pm #4023883

emmanuelF-6

I increased Memory Limit as per your request.

/** Memory Limit */
define(\'WP_MEMORY_LIMIT\', \'256M\');
define( \'WP_MAX_MEMORY_LIMIT\', \'256M\' );

June 17, 2019 at 4:35 pm #4037093

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I have set up a staging site so that we can test this further. Please upload a copy of your theme here:
Login: hidden link
Username: demo
Password: pXW65V2jnN6b

Let me know once the theme is activated and I will continue troubleshooting there. Thanks!

July 1, 2019 at 5:13 am #4115601

emmanuelF-6

Hello I see hidden link

July 2, 2019 at 6:58 am #4124417

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

I have created another sandbox for you:
Login: hidden link
Username: demo
Password: vAy86vQL5Au7

These sandbox sites expire after nobody has worked on them for approximately 7 days.

Regards,
Bruno Kos

July 4, 2019 at 4:32 am #4140321

emmanuelF-6

Hello,

I have installed the theme Nobro child on hidden link

I also installed all plugins necessary for the theme to work.

Remember: the problem is LOGO not displayed in FR version of hidden link (EN, FR)

July 4, 2019 at 6:02 am #4140387

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Can you check now?
hidden link
hidden link

I believe I achieved this "accidentally" - I've set the logo when WPML was activated and it did not work for some reason. Therefore, I've tried deactivating WPML, setting the logo in the Branding settings and then I activated WPML back and it seems to be working now.

Can you try the same on your site? I only deactivated the core WPML plugin.

Regards,
Bruno Kos

July 4, 2019 at 6:44 am #4140505

emmanuelF-6

Hello Bruno and thank you for your kind help.

It does not work unfortunately. I followed your steps:

1. Deactivate WPML plugins (all WPML plugins)
2. Re-Uploaded in Theme Settings / Branding the logo
3. I activated all WPML plugins
4. I enabled new language FR
5. I checked hidden link

July 4, 2019 at 7:43 am #4140827

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Can you check now? Let me explain what I tried and it seems to be working:
- I switched the language in the admin bar
- I noticed that no images were set for "Logo dark variant" so I used the same you used for the light version
- Logo by default was set to Dark, and since no images were set for Dark, nothing was loaded into French version

I am attaching an image which illustrates this.

Regards,
Bruno Kos

July 4, 2019 at 7:52 am #4140873

emmanuelF-6

OK,

We made great progress here, 2 problems remain (attached):

1. See the translated NAVIGATION menu Should not be there
2. See the width that is smaller compare to the English one (it makes the logo to be over the picture) see hidden link and hidden link

July 4, 2019 at 7:52 am #4140877

emmanuelF-6

Screenshot

July 4, 2019 at 8:16 am #4141105

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

I would say that the solution for this is the same as I did for the logo images - I switched dashboard languages and noticed that the header layout was not set in the same way. I did this and it seems to be working now.

Therefore, if you see some other discrepancies between any layout option which you can set in the theme options, I suggest you do the same - switch language and check if these options are the same. If they are not, then save them in the French language..

I guess that we can explain this to ourselves in the following way:
- it is a bad thing because theme options are not synchronized between languages
- it is a good thing because you can completely alter the the look of the theme in another language

Regards,
Bruno Kos

July 8, 2019 at 3:39 am #4158953

emmanuelF-6

My issue is resolved now. Thank you to Lauren and Bruno.