This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 1.28 hours from now. Thank you for your understanding.

This topic contains 7 replies, has 2 voices.

Last updated by farukS-3 3 months, 2 weeks ago.

Assigned support staff: Noman.

Author Posts
June 27, 2019 at 5:44 pm #4101907

farukS-3

Hi,
I have a really incomprehensible problem. I added the logo in 5 languages . In each language the logo in its own language appeared. After a while, the problem occurred.

While the logo in 4 languages appears correctly, only the logo on the English pages appears in Turkish.

It’s ridiculous but unfortunately I’m having something like this.

Screenshot of the logo in Turkish : hidden link

string translation in web logo: hidden link

string translation in retina : hidden link

Screenshot showing logo on site : hidden link

web page is hidden link

How can I fix this problem.

Best regards.

June 27, 2019 at 6:40 pm #4102181

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support. Could you please follow below steps and let me know how it goes?

- Please make sure minimum requirements for WPML meet:
https://wpml.org/home/minimum-requirements/

- Please make sure your theme is WPML compatible. Here is our compatible theme list. You can search your theme in this list. https://wpml.org/documentation/theme-compatibility

- Also make sure you are using an updated version of the theme and plugins.

- Please try to re-save the translation:

1. Go to WPML >> String Translation >> Search and Open your translated text >> delete the translation >> Save.

2. Then again go to: String Translation >> Re-add your translated text >> and re-save. Make sure that "Translation is complete" checkbox is selected.

3. Please delete all sorts of caches on your site / server cache if any / plugin cache / CDN cache (if any), clear browser cache and then see if it resolves the issue afterwards.

- Please add the debug report in the Debug Information box. I have also enabled debug info box for your next reply: https://wpml.org/faq/provide-debug-information-faster-support/
- Please delete all sorts of caches on your site / server cache (if any) / plugin cache / CDN cache (if any), clear browser cache and see if this resolves your issue.

- If still issue persists, please check for a possible theme and plugin conflict. To do that you can switch back to any default theme (e.g. Twenty Seventeen theme), Disable all plugins except WPML and see if this issue goes away with default theme and only WPML activated?

Please let me know if this resolves your issue or you need further assistance with this issue.

Thank you

June 30, 2019 at 12:39 pm #4114167

farukS-3

Hi,
I followed the steps you wrote. Unfortunately I couldn't change the logo.
Best regards

June 30, 2019 at 5:24 pm #4114701

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

To further debug this issue, please provide temporary access (WP-Admin and FTP Login info) to your site (preferably staging site), so that I can look into your setup and debug the issue.

Your next answer will be private which means only you and I have access to it.

=== Please backup your database and website ===

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

Thank you

July 1, 2019 at 8:17 am #4116483

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

WP login info that you have provided is not working here. Could you please provide me working login please. I have enabled private input box for your next reply.

Thank you

July 1, 2019 at 11:16 am #4118205

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

I have logged in to your site and activated Pregnancy parent theme and with parent theme logo working perfectly fine in all languages as you can in attached screenshots.

This issue is only in your child theme custom code and we cannot consult much on the custom code or requirements, as it falls in custom programming work for your site, we recommend contacting one of our certified service providers for such cases:
https://wpml.org/documentation/support/wpml-contractors/

Thank you

July 1, 2019 at 3:35 pm #4120981

farukS-3

Hi Noman,
Would you please check the website. Except for Arabic, they all became Turkish logo. I can't believed it. I checked a couple of times to make sure.This problem is about to drive me crazy ...

July 1, 2019 at 3:53 pm #4121035

farukS-3

My site is crashed. Immediately I have to setup again