This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by giacomoC-11 12 months ago.

Assigned support staff: Mihai Apetrei.

Author Posts
October 23, 2018 at 11:32 am #2842000

giacomoC-11

I am trying to:

I have one Global header in Beaver Builder Themer. I switch to the second language (French) and edit the logo link to point to the home page for that language. Save everything and test. when I click the logo on the English site, it goes to the French site. The exact opposite happens when I change the link on the English page header.

I have set the WP mem Min to 128 using php.ini and I see that it is set to that in my php_info.php, but WPML stills shows WP at 40. I've cleared the cache and deactivated all other plugins, but that hasn't helped. WP=4.9.8 and PHP = 7.2 Is there a solution for this?

Link to a page where the issue can be seen:

hidden link

I expected to see: English homepage when I click the header logo

Instead, I got: the French home page

October 23, 2018 at 3:38 pm #2843308

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

Can you please let me know what's the link that you added to the EN language logo?

Regarding the memory question you can add this code to your wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '256M');

Paste it just before:

/* That's all, stop editing! Happy blogging. */

These settings can be limited directly by your hosting provider, so I recommend you to contact and ask them to modify them directly. If you can get even higher values It would be great.

I will be waiting for your response.

Kind regards,
Mihai

October 23, 2018 at 3:48 pm #2843364

giacomoC-11

Thank you, Mihai. The problem is that as soon as I link the English home page to the logo in the English header, then the French page link changes, too. So, I can have it one direction or the other.

For the English logo, I use hidden link and for the French I use hidden link. let me know if that's not right.

I had tried pasting define mem code into my wp-config.php, but that apparently doesn't work with my Godaddy Linux setup; my php_ifo.php never changed from 64M. So, I called Godaddy and they told me I had to create a php.ini and put it in there, which did work as far as my php_info.php was concerned. It shows up as 128M. I can change it to 256 if you think it really needs it. I was just going by the requirements page on WPML.

Thanks,

Jack

October 24, 2018 at 2:07 pm #2846754

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi Jack.

128M is fine, no need to make it bigger than that for the moment.

Regarding the logo link issue, I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of the site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box.

The private box looks like this: hidden link

October 25, 2018 at 1:05 pm #2849907

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

I have been running a little more tests on your site.

From what I can see, on the English version of the site, there are no issues where the logo would send to the French version.

However, we have issues happening on the French version of the site, as you already said.

From my tests, I can see that for example if we edit the FR Homepage (Accueil page) with Beaverbuilder, the global header used on the page is called "NLS Global Headfer French" while if I go to the Etudiants page and edit it with Beaverbuilder, it is using the "NLS Global Header" (so it is using the English version of the header instead of using the French one).

So the issue is that some French pages are still using the English global header instead of the French one; that is why we are having the logo sending to the English homepage. You would need to go to those pages that are still using the English global header and make sure they use the French global header.

Please let me know if this solved your issue or if you still need help.

I will be waiting for your response.

Kind regards,
Mihai

October 25, 2018 at 2:05 pm #2850086

giacomoC-11

Ah! Thank you, Mihai! I had been trying to get down to one global header and didn't realize some of the pages had an English version while others had a French one. Unfortunately,Beaver Builder shows EVERY module regardless of the language, so things get a bit confusing. I take it then that there is no way just to have one Global header with a logo that will redirect to the proper language? I'm going to have at least 8, if not more, languages, and I'd rather use the same header if possible.

October 26, 2018 at 2:19 pm #2853238

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

I totally understand the situation you are in at this moment.

Logos can be translated from String Translation but for that, you would need to display them by using the WordPress theme that you have installed and not an element from a content builder (Beaver Builder, WP Bakery etc.).

To translate the global header using the global header functionality that comes with Beaver Builder, you would simply need to create one header for each language and use the right one under each language.

Our plugin is compatible with Beaver Builder and you can find more about that here:
https://wpml.org/documentation/plugins-compatibility/beaver-builder/

However, for custom implementations like this, where we have only one global header and the logo link should change in the generated content for each of the languages, I suggest to contact our Contractors as it requires custom work:
https://wpml.org/contractors

I hope this was helpful information.

Kind regards,
Mihai

October 27, 2018 at 9:04 am #2854962

giacomoC-11

My issue is resolved now. Thank you!