This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by Dennis 6 months ago.

Assigned support staff: Dennis.

Author Posts
April 12, 2019 at 12:24 am #3593409

matthewK-11

Tell us what you are trying to do?
I'm trying to logout of an ultimate member account in a non default language, but the nondefault logout is not set in ultimate member. If I try and logout, it doesn't redirect me to the homepage that I set, but instead gives me a not found error. I suspect that this is because on the ultimate member' setting page, I only linked the sign out page of the default language. Is there any integration between wpml and ultimate member where we can have different settings for ultimate member based on the language wpml is using? Everything works fine for the default language though. My default language is Simplified chinese, and I'm trying to add English and Traditional Chinese.

Is there any documentation that you are following?
I tried following these two guides. The first one I didn't work, and the second link, I'm not sure what Laura was referencing when she mentioned admin_texts and core page IDs.

hidden link
https://wpml.org/forums/topic/ultimate-member-logout-link-not-working-in-different-languages/

April 12, 2019 at 7:02 am #3595393

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

Welcome to WPML Support forum.

Could please try to add this code snippet to WPML > Settings > Custom XML Configuration.

<wpml-config>
  <admin-texts>
    <key name="um_options">
      <key name="core_logout"/>
    </key>
  </admin-texts>
</wpml-config>

Then go to WPML > String Translation and translate the core_logout page IDs to the ID of the translated pages.

Does it help? Please let me know.

Kind regards,
Dennis

April 13, 2019 at 2:24 am #3602739

matthewK-11

Hi Dennis,

I added this snippet and updated the ID in string translation to the translated logout page, but there's the same error. I suspect it might have something to do with the page that it's redirecting to. On my end, I have a home page for non-logged in users that's translated in both the default language (simplified Chinese) and the non default language (English). The default home page doesn't have any extra language parameters whereas the non default home page has the language parameter. (/?lang=en)
When I try to log out of the English version, it url on the 404 page ends with /en?lang=en, but the non English homepage is suppose to be /?lang=en. I think this might be the problem. What do you think?

Thanks

April 15, 2019 at 5:06 am #3609767

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

Thank you for your reply.

To debug the issue further, I would like to request temporary access (/wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. Your next reply will be set to private.

Maybe I'll need to replicate your site locally to continue debugging and escalate if necessary. For this I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Please confirm if this okay with you.

Our Debugging Procedures
I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to BACKUP the site before providing us access.

Privacy and Security Policy
We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Kind regards,
Dennis

April 16, 2019 at 6:52 am #3618553

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

Thank you for providing us with the access details.

I noticed that your Ultimate Member plugin is quite outdated. Could you please update your plugin to latest version. Then re-save your permalink settings at Settings > Permalinks.

Note: Please backup your site completely before updating the plugin.

Ultimate member also has known issues with 'Language name added as a parameter' URL format. If possible after updating Ultimate Member, switch the Language URL format
at WPML > Languages to Different languages in directories. Then, on Settings > Permalinks, select the 'Post name' option and save your settings.

https://wpml.org/faq/server-setting-for-languages-in-directories/

Kind regards,
Dennis

April 16, 2019 at 8:37 pm #3625477

matthewK-11

Hi Dennis,

I just updated Ultimate Member. I tried using switching the URL format to Different Languages in directories, but I got an error. I went added the mod_rewrite in .htaccess, but it still has the same error. Also, why are you suggesting to use Post name in permalinks. Could I not keep the settings as simple?

Thanks

April 17, 2019 at 6:41 am #3627533

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

Is your wordpress site installed in a sub-directory? If yes, this guide from wordpress will help you set it up properly:

https://codex.wordpress.org/Giving_WordPress_Its_Own_Directory

It could also be that wordpress cannot write to your .htaccess file. Please check if the directory ownership and permissions are configured correctly.

Kind regards,
Dennis