Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 2 voices.

Last updated by Carlos Rojas 2 years, 6 months ago.

Assigned support staff: Carlos Rojas.

Author Posts
March 29, 2019 at 7:23 pm

Eduardo Torres Chacon

Buenas tardes.

Hemos modificado el idioma por defecto de la web de español a inglés. Ahora cuando hacemos click en cualquier enlace que no sea un item del menú, siempre nos redirecciona a la web en Inglés, inclusive si estamos en una página que hemos indicado que era en español. Sin embargo, si indicamos que el idioma por defecto es el español, no da ese error.

¿Cómo podríamos solucionarlo?

Gracias de antemano.

March 30, 2019 at 6:09 pm #3499077

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hola,

En este caso le recomiendo que realice los siguientes pasos:
- Cree una copia de seguridad del sitio completo.
- Ve a WPML -> Settings -> Translate Link Targets -> Haz click en el botón 'Scan and adjust links'
- Ve a Settings -> Permalinks -> Haz click en el botón 'Save'.

Me puede decir el resultado de los pasos anteriores?

Saludos,
Carlos

March 30, 2019 at 6:45 pm #3499135

Eduardo Torres Chacon

Hola Carlos.

Lo he hecho y todo sigue exactamente igual.

Gracias de antemano.

March 30, 2019 at 6:52 pm #3499141

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hola,
Muchas gracias por su respuesta.

En este caso me gustaría pedirle que borre cualquier memoria cache que pueda existir, incluyendo la del navegador y contacte a sus proveedores de hosting para que borre cualquier memoria cache que exista de parte del servidor.

Luego le pido que edite la página en cuestión -> Haga algún pequeño cambio en el contenido -> Guarde los cambios -> Actualice la traducción.

Me puede decir si el problema desapareció?

Saludos,
Carlos

April 1, 2019 at 12:03 pm #3507635

Eduardo Torres Chacon

Hemos intentado las dos soluciones, limpiado las cachés tanto en el servidor como en el navegador, además de modificar una de las páginas afectadas sin resultado.

April 1, 2019 at 5:18 pm #3510349

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hola,
Muchas gracias por su respuesta.

Antes de continuar necesito pedirle que actualice todos los plugins desactualizados, especialmente los de WPML y compruebe si el problema persiste. Funcionalidades desactualizadas pueden causar conflictos en el código.

Saludos,
Carlos

April 1, 2019 at 5:30 pm #3510365

Eduardo Torres Chacon

Buenas tardes.

He actualizado todos los plugins, y repasado todos los pasos hasta ahora. El problema persiste. Seguimos a la espera de instrucciones 🙂

Un saludo

April 1, 2019 at 7:22 pm #3511229

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hola,
Muchas gracias por su respuesta.

He aplicado varios pasos de 'troubleshooting' y el problema parece resuelto. Puede confirmar que el problema se resolvió?

Nota: Le recomiendo que vaya a Settings -> Permalinks -> Seleccione la opción 'Post name' y guarde los cambios.

Saludos cordiales,
Carlos

April 2, 2019 at 8:04 pm #3520571

Eduardo Torres Chacon

Buenas.

Lo sentimos, nosotros no vemos el problema resuelto. Si seleccionas el idioma español desde la página principal y haces click en cualquier enlace sigue saltando la página en inglés. Si además hacemos lo que nos indicas de los enlaces permanentes las páginas devuelven 404.

Gracias!

April 2, 2019 at 8:23 pm #3520711

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hola,
Muchas gracias por su respuesta.

He vuelto a revisar la página de inicio en Español y veo que hay links que dirigen al idioma correcto y otro que dirigen a páginas en Inglés. En este caso me gustaría pedirle que edite la página de inicio y corrija manualmente las URLs de los enlaces -> Guarde los cambios y actualice la traducción.

Me puede decir si el problema persiste?

Saludos,
Carlos