This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 2 replies, has 2 voices.

Last updated by verenaL-4 2 months, 1 week ago.

Assigned support staff: Bruno.

Author Posts
August 7, 2019 at 7:29 pm #4357691

verenaL-4

Tell us what you are trying to do?
I installed WPML and set the site language to german (it was in english as a standard). After that I changed the url names (because there was a notification with a link). After I did this I got an 404 Error message and I could not see my pages anymore. I wanted to search them in the pages tab, however, they were not there anymore. I did not delete them.
In the database they are available.
Now actually my whole site content is lost after installing WPML and setting the language - how can I restore the lost pages?
It is a wordpress multisite

What is the link to your site?
art-y-zen.ch

August 7, 2019 at 9:22 pm #4358325

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you for contacting us. Please, follow the steps below:

Click on the WPML > Support > Troubleshooting. Look at the "Clean up" and click on these buttons:
-- Clear the cache in WPML
-- Remove ghost entries from the translation tables
-- Fix element_type collation
-- Set language information
-- Fix post type assignment for translations

After following these steps, are the pages displaying correctly?

Thank you.

August 8, 2019 at 2:33 pm #4363857

verenaL-4

My issue is resolved now. Thank you!