This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 14 replies, has 3 voices.

Last updated by Andreas W. 2 weeks, 3 days ago.

Assigned support staff: Andreas W..

Author Posts
September 4, 2019 at 12:57 pm

maxL-15

Lost password is not working on everything except for NL. For NL it is working, when you are at hidden link you get the nice The7 passpword reset. Unfortunately for other languages this is not working. The permalink of the other languages is just correct.

September 4, 2019 at 2:25 pm
September 7, 2019 at 7:10 am #4528689

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello,
Laura is off for a few days so I'll continue troubleshooting this issue from now on.

Could you please tell me where did you find the endpoints you mentioned to Laura, please?

And one more thing, is the link label the problem or is it the actual target link? Or is it both?

This information will help me figure out where to look and how to test it.

Thanks in advance.

September 7, 2019 at 7:14 am #4528691

maxL-15

Hi there,
the endpoint is in Woocommerce > Settings > Advanced.
We also tried tring translation and some other things that didn't help.
The permalink in all languages for /lost-password looks just completely fine. Only when visiting the page, it's showing you a 404. I also contacted The7 theme about this, and they are referring me to WPML.

September 9, 2019 at 8:52 am #4534839

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

The problem is with the "shop" slug.
I tested it with the italian shop slug. i changed it to "shop-it" and then the entire endpoint started working.

I suggest that you translated everything and don't leave anything without a translation (i'm talking about the shop, my account and lost password slugs/endpoint) and make them different from the original one, that way they will not create issues and will work.

I suspect this is a WPML bug, though, so could you try to first change from domains to subdirectories and/or parameteres for a brief moment and see if the problem is still there (do not try to test it with italian, because that one works at the moment, try it with English, for example)

to change from Domains to Directories/parameters please go to WPML > Languages > Language URL format > Select another option > Save and resave the permalinks in settings > Permalink.

September 12, 2019 at 2:26 pm #4561725

maxL-15

I will try the above.

In the meantime, I am unable to submit new tickets. Sucuri is blocking my IP addresses.

Please fix this asap. I need to open a new one.

September 12, 2019 at 5:34 pm #4563763

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

That should be solved by now, sorry for the trouble.

Please flush your browser's cache and try again.

September 16, 2019 at 2:59 pm #4581693

maxL-15

Hi, the lowest endpoint shows in English flag with Dutch text. That is incorrect. I don't see this endpoint in Woocommerce Advanced settings, How to change this to real English?

Also, I changed the shop pages but I am not able to visit the productcategories now : hidden link

September 17, 2019 at 10:58 am #4587819

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello!
Welcome to WPML Support.
I'll do my best to help you solve this issue.

It seems that is a custom endpoint and that has been added or through a plugin option (most likely) or directly through the plugins' code.

i couldn't find where that option is, so i ask you if you can tell me which plugin should be creating that endpoint so i can investigate further.

September 20, 2019 at 2:07 pm #4612929

maxL-15

Hey, I translated all endpoint but they are not working:

hidden link
hidden link
hidden link
hidden link

For example a few links. Please help.

September 23, 2019 at 3:34 pm #4625427

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

My colleague Alejandro is sadly not available today but I am glad to be able to assist you.

As Alejandro already mentioned it seems that you are using an additonal plugin that is causing that WooCommerce Endpoints are getting registered in an unexpected way.

In fact, if you go to String Translation and select from the domain filter dropdown "WP_Endpoints" you will be able to see all those Endpoints. Some Endpoints are for some reason appearing here once for each language.

I have now assigned each Enpoint to its proper language and I would like to ask you to try translate them all.

I hope this will solve the issue, otherwise we will need to find out which plugin creates the additonal Endpoints and test it for compatibility. For such tests it will onlz be necessary do de/reactivate plugins until the issue disappaers and it can be determined which plugin is responsible for the additonal added endpoints and the 404 errors.

Let me know about the outcome.

Kind regards
Andreas

September 23, 2019 at 5:18 pm #4625861

maxL-15

This is ridiculous. there is no such plugin that creates all these endpoints except for Woocommerce itself. I translated the lost-password endpoints and it is still not working. I rather think this is a fault of WPML or the database of WPML, because before this never looked like this.

The endpoints are also doubled in the woocommerce settings. So please investigate that with me to fix. Probably the string translating list will disappear too and there should be only 1 of each endpoint.

September 23, 2019 at 11:49 pm #4626825

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I am sorry about the confusion, as it turns out that the issue is simply based on String Translation and not on another plugin.
I tried to run a moment your site only with WooCommerce and WPML plugins and I had the same result. Disabling String Translation solves the issue.
I have also deleted the duplicated Endpoints from String Translation. I realized that for some reason they have been registered again, which for I excluded the domain from registrating further strings to the String Translation.

It might further be an unexpected compatibility issue with The7 Theme 7.7.7 which for I would kindly like to ask you to install the default fresh version of the theme on the following test site:

One-Click Login: hidden link

Leave me a short notification once the Theme is installed.

Further, you could enable the wp-debug feature to see if there are any current PHP errors given.
More information about how to activate this feature you can find here:
https://wpml.org/documentation/support/debugging-wpml/

Let me know about the outcome.

Kind regards
Andreas

September 27, 2019 at 9:44 am #4652771

maxL-15

All WP Endpoint lines came back in String translation again. Can you fix this again? It doesn't look good now. I will install the7 on your link.

September 27, 2019 at 9:51 am #4652871

maxL-15

Theme is installed on sandbox.

The topic ‘[Closed] Lost password doesnt work’ is closed to new replies.