This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by Raja Mohammed 5 months, 4 weeks ago.

Assigned support staff: Raja Mohammed.

Author Posts
April 19, 2019 at 3:07 am #3642933

hopV

After update Woocomerce Multilingual, Woocomerce and Flatsome Theme this morning. I lost the image product gallery for the Vietnamese version.

But the image product gallery for the English version is still working fine.

Can you tell me what happens, please?

Please have a look at the attachments

April 19, 2019 at 4:05 am #3643479

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

We have already identified the issue, the issue is now escalated and notified to our developers.

There are two possible workarounds that you can try

1- Rollback to previous WCML version (4.5) you can get the previous WCML version from https://wpml.org/download/woocommerce-multilingual/?section=changelog,

(OR)

2- If you can handle a quick fix in the code.
Please open the file class-wcml-products.php located in the path wp-content/plugins/woocommerce-multilingual/inc/class-wcml-products.php

Approximately at line 689 comment the line

$data['_product_image_gallery'] = null;

Let me know the results.

Kind regards
Raja

April 19, 2019 at 8:57 am #3644245

hopV

Hi,

I follow you, delete the Woo Multilingual and re-install the 4.5 version. Then my website is becoming very slow now. Almost cannot load, so I have to upgrade the Woo Multilingual to be 4.6 and the site can load but also very slow.

Can you tell me how to do please? To be honest, the WPML is the most complicated and not safe plugin I have ever used. Can you improve it in the future?

Each time I update, each time I have a various problem...

I lost many efforts to translate my site, otherwise, I already remove this plugin and request for the refund already

Can you tell me why my site becomes extremely slow now and how can I fix it, please?

Thank you
Steve
hidden link

April 19, 2019 at 12:58 pm #3645811

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Steve,

Kindly apologize for the issue. Our developers are fixing it and an update will be released very soon.

I'm not sure about the reason for the slow load of the site, is it happening in the backend or in the site frontend ?. It is possible String translation might scanning the plugin strings but that would be a temporary thing please confirm whether you are having slow load issue now.

Please try applying the second fix in the latest version of WooCommerce multilingual (4.6) mentioned in my previous reply.

Let me know the results

Kind regards
Raja

April 22, 2019 at 8:27 am #3654545

hopV

Hi,

Thank you for your reply. I think I will wait for the new update because I am not IT person.

Please do not forget to release the new update soon.

Best Regards
Steve
hidden link

April 22, 2019 at 9:05 am #3654743

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Steve,

Sure we will release a fix soon, the fix is in testing phase it will be available as soon as the testing is done. Anyway, I will keep you posted.

Thanks for your understanding and cooperation

Kind regards
Raja

April 26, 2019 at 9:29 am #3689245

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

We have released a new version of WooCommerce Multilingual 4.6.2 with the fix for your issue, Please update to the latest version. As a security step secure a backup of your site.

Please let me know the results

Kind regards
Raja