This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 12 replies, has 3 voices.

Last updated by Bigul 8 months, 3 weeks ago.

Assigned support staff: Bigul.

Author Posts
January 17, 2019 at 3:25 pm

robertF-24

I am trying to: regain some lost fields in my homepage translation from Danish to English

Link to a page where the issue can be seen:hidden link

I expected to see:

Instead, I got:

I was translating an entire section of the Danish home page. I saved and closed the page. My client made a change on the danish page, and now when I tried to continue the translation to English, a field is missing and a large part of what I have translated is missing.

January 18, 2019 at 8:52 am #3105134

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

I went through the Homepage and its translation. But not able to reproduce issue exactly. Therefore please share me a couple of screenshots for the better understanding of the issue.

Have you used any Custom Language Configuration in WPML>>Settings>>Custom XML configuration? Because on the homepage, you were using few custom shortcodes for WPBakery Page Builder, like minti_box, minti_headline etc.. Please check the following documentation for more details.

https://wpml.org/documentation/support/language-configuration-files/#page-builder-content

https://wpml.org/documentation/support/language-configuration-files/

--
Thanks!

Bigul

January 18, 2019 at 10:08 am #3105406

robertF-24

I Bigul,

Here are my screen shots. The first set is what the homepage looks like in Danish. The second set is of the translation screen, where I am to enter the English text.

It should be 100% complete, but instead it is only 9% complete, and now all the of Danish and English text is missing. There is no way to edit the homepage text. Could you please me help find it?

Robert

January 18, 2019 at 2:50 pm #3106489

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Robert,

Thank you for the details. This may be happened because of the sync issue between the original language and translation. Have you edited the original language page before completing the translation? It is not recommended. Because it will make conflicts.

I have added the language configuration for the WPBakery Page Builder custom shortcodes in WPML>>Settings>>Custom XML configuration. We have to add language configuration for the Custom Shortcodes. Then only its contents will appear for translation in WPML Translation Editor.

Please try the following steps after a site backup and let me know your feedback.

1) Open the English Homepage for edit in WPML Translation Editor
2) Click on *Copy from original* button on the top
3) Click on *Copy to empty fields only* button of *Copy from original* popup
4) It will add the values to the empty fields
5) Complete the translation by choosing *Translation is complete* option of each field
6) Click on *Save* button
7) Then update the Danish Homepage after a minor edit to refresh translation settings
8) Open the English Homepage for edit in WPML Translation Editor again and check the missing contents are showing for the translation or not

Please check the attached images for more details.

--
Thanks!

Bigul

January 20, 2019 at 6:06 pm #3109785

robertF-24

Hi Bigul,

Thanks for your reply. I tried to follow your steps, and I got as far as step 3, "Copy to empty fields only," the fields where most of the page's content is, does not show up in any translator field. It's missing, and I'm not sure why. If it's unclear, please let me know, I'm happy to chat with you in real time. 🙂

Robert

January 21, 2019 at 11:33 am #3112092

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Bigul is off for today, so I am taking care of this ticket today, I hope this is Ok. 🙂

the fields where most of the page's content is does not show up in any translator field

It's ok if the page content is not showing, just mark the available content as translated and continue the steps as provided by Bigul. The steps that Bigul mentioned will help you to retrieve the content once you complete the available translations as marked and try to re-translate again.

Let me know if any other steps are confusing.

Thanks

January 21, 2019 at 11:57 am #3112184

robertF-24

Hi Shekar, I just went through Bigul's steps, and my lost translation has not come back ... Not sure what to do now. Could you please take a look?

January 22, 2019 at 11:36 am #3116014

robertF-24

Hi Shekar, Have you had a chance to look at the site? How should I proceed forward?

Bigul, are you still assigned to this, or should I be asking Shekar?

Robert

January 22, 2019 at 1:04 pm #3116448

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Robert,

Thank you for the updates. I am back and had a quick check on the Homepage and its translation.

Maybe the issue has happened because of the sync conflicts between the original language and translation. Therefore please let me know you have updated the default language homepage before completing its translation or not. Because it is not recommended and there will be a strong chance for conflicts like this.

Please let me know the following for tracking the issue.

a) Do you have a backup before you had the translation lose issue?

b) Have you updated the Homepage(minor edit to refresh the translation settings as per our recommendation) after completing the English translation(from 9% to 100% after *Copy to empty fields only* action)

--
Thanks!

Bigul

January 22, 2019 at 1:19 pm #3116566

robertF-24

Hi Bigul,
To answer your question, I do have a backup. and I did update the homepage.

Should I try to reinstall the backup?

January 22, 2019 at 5:47 pm #3117744

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Robert,

Thank you for the updates. Is it possible for you to install the backup in a test space like a staging site? So we can cross check it further without affecting your live site. Please let me know your feedback.

--
Thanks!

Bigul

January 29, 2019 at 10:17 am #3139127

robertF-24

Hi Bigul. Is it possible to chat about this in realtime?

January 29, 2019 at 6:25 pm #3141280

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Robert,

For your kind information, right now we don't have an option to chat on the open support tickets. And this issue requires further debugging.

If possible please install the backup in a test space like a staging site. It will help us to debug the issue further without affecting your live site. Please let me know your feedback.

I am enabling the private information for the next reply. So you can share the credentials of the staging site.

--
Thanks!

Bigul

The topic ‘[Closed] Lost translation’ is closed to new replies.