Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Carlos Rojas 2 years, 7 months ago.

Assigned support staff: Carlos Rojas.

Author Posts
February 13, 2018 at 11:10 pm #1516910

philipped-14

I am trying to: send newsletter in the language of the user when publishing a post

I expected to see: each user receives the newsletter in his/her language as declared in his/her profile

Instead, I got: the newsletter is only sent in one language, the default one

How to have one of the following solution
- all the users received in one newsletter the original post and its translations
- each user receives the newsletter in his/her own language

Regards

Philippe

February 15, 2018 at 2:17 pm #1519072

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello Philippe,
Thank you for contacting WPML support.

1.- The MailPoet plugin is not present in our plugins compatibility list: https://wpml.org/documentation/plugins-compatibility/
So, it's not compatible with WPML and this may cause some problems.

2.- To fix these issue we have to go through WPML compatibility process.

But, we have to go through some tests before proceeding to go through the compatibility process.

-Please test the issue in the minimal environment:
To do that, disable all non WPML plugins and activate one of the default themes(e.g Twenty Seventeen) then test the issue and share the results here .

-If you are comfortable with the code, you can check the issue by looking for the string in the plugin PHP files and check if they are properly registered for translation.
--Please have a look at this article that illustrates how to register strings for translations in different ways : https://wpml.org/faq/getting-string-translation-to-work/
--Please make sure that the plugin doesn't use constants or variables in the string domain of the gettext function. Please check this article as well : hidden link

Please let me know the results of these previous steps.

3.- Please provide the debug information of the site. In this link you will find the steps to follow: https://wpml.org/faq/provide-debug-information-faster-support/

Kind regards,
Carlos

The topic ‘[Closed] MailPoet’ is closed to new replies.