This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by basK-7 4 months, 3 weeks ago.

Assigned support staff: Bigul.

Author Posts
May 15, 2019 at 11:14 am

basK-7

I am trying to: get products to show for each language

Link to a page where the issue can be seen:hidden link

I expected to see: single products like at;hidden link

Instead, I got: double products

May 15, 2019 at 2:27 pm #3817591

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

This happening because of the following reasons.

a) Products are not translated from English(default language) to other secondary languages and you have the same products in all the languages

b) You have chosen *Translatable - use translation if available or fallback to default language* option as the translation preferences for the *Products* Post Types and *Product Categories* taxonomies in WPML>>Settings. So we will get the default language Products in the secondary language without translating or duplicating it.

Therefore please choose *Translatable - only show translated items* as the translation preference for the *Products* Post Types and *Product Categories* taxonomies in WPML>>Settings(after a backup). Then check you are getting the expected result or not.

Please check the attached images for more details and let me know your feedback.

--
Thanks!

Bigul

May 16, 2019 at 11:17 am #3825335

basK-7

Hi Bigul,

Thanks for the info. I've done as you recommended. The products remain unconnected between the 4 different languages. What's the easiest way to connect them?

Thanks
Bas

May 16, 2019 at 3:13 pm #3827375

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Bas,

Thank you for the updates. Please try the following steps after a backup and let me know you are getting the expected result or not.

1) Open a secondary language Product for edit, then click on *Connect with translations* link of *Language* widget on the right side
2) Search for the relevant Product in the primary language
3) Choose the Product and click on *Ok* button
4) Uncheck the *Make "Secondary language" the original language for this page* checkbox and click on *Assign* button
5) After the *Assign* action, make sure the secondary language Product has become the translation of the chosen default language Product or not

Please check the attached images for more details.

--
With Regards

Bigul

May 17, 2019 at 10:13 am #3833213

basK-7

Hi Bigul,

Issue is solved, products are now connected.
But the products are variable and the variations are now not showing up as a choice when looking at the 3 translated languages. (they only show in the original English version)

I've already made sure all attributes are translated and linked and then used the troubleshoot variations sync function... but still the problem exists.

Any ideas?

Thanks
Bas

May 17, 2019 at 2:46 pm #3835305

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Bas,

Thank you for the updates. Please updates the Products in the default language after a minor edit to refresh the translation settings and check you are getting the expected result or not. Because normally Product variation is copied to secondary language Products from the default one.

Are you using the same contents(title & descriptions etc...) for the products in all the languages?

--
With Regards

Bigul

May 20, 2019 at 5:26 am #3843747

basK-7

After making the suggested changes, I reuploaded all products (with WP All import + Woocommerce). Now all products and variations seem interconnected between the 4 languages.
My issue is resolved now. Thank you!