This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 18 replies, has 2 voices.

Last updated by Radu 3 months, 2 weeks ago.

Assigned support staff: Radu.

Author Posts
July 5, 2019 at 8:49 am

rickardR-2

Hello,

Main Menu disappeared after translation and I can not find it anywhere. It disappeared from the rest of the menus. Language switcher flags disappeared as well and currently, the site is no header whatsoever.

Would you be so kind as to advise how to find the Main Menu and fix this issue?

July 5, 2019 at 9:43 am #4149755

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Rickard,

I just checked your website and I could see that no elements are displayed at the top of the page (and I checked a few different pages, not just home). Also, the menu is not set through Dashboard → Appearance → Menus → Menu locations. In this case, can you tell me how the menu at the top is added to the default language so I can check why is it not displayed on the secondary language, please?

Thanks,
Radu

July 5, 2019 at 9:52 am #4149915

rickardR-2

Can you tell me how the menu at the top is added to the default language so I can check why is it not displayed on the secondary language, please?

The webpage was designed by developers, so I don't have the answer exactly on that. But I know they build the header using Elementor page builder. But the Norwegian version was there in the start, but after I translated the header in theme builder, it just disappeared.

Rickard

July 5, 2019 at 9:54 am #4150011

rickardR-2

The developer never used the theme, just Elementor.

July 5, 2019 at 9:55 am #4150019

rickardR-2

Think they build the menu with this: hidden link

July 5, 2019 at 10:23 am #4150259

rickardR-2

I think they inform about it here: https://wpml.org/documentation/plugins-compatibility/elementor/

July 5, 2019 at 10:57 am #4150451

rickardR-2

They have the same issue: https://wpml.org/forums/topic/header-bar-disappeared-on-translated-pages-only/

July 5, 2019 at 11:26 am #4150727

rickardR-2

They are added using Elementor, see attached image.

July 5, 2019 at 12:19 pm #4151253

rickardR-2

I think the reason is that after the translation of theme builder content, they lose their instance. They are why they disappear.

July 5, 2019 at 2:10 pm #4151931

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Rickard,

Thank you for sending me all these info. I was looking at the settings of your website in order to find out why is this happening.
I could see that you opened a new ticket here: https://wpml.org/forums/topic/header-bar-for-the-translated-pages-in-norwegian-disappeared/. Can you tell me if describing the same issue, please? I think that the main menu will appear once we figure it out why the translated header is not appearing.
As I can see, the header in Norvegian here hidden link is missing the menu (compared to the English header hidden link). Can you tell me if you edited this recently? Also, have you tried to add the menu here, to the sides of the logo, and see how things look on the page?

Thanks,
Radu

July 5, 2019 at 2:17 pm #4152011

rickardR-2

After the translation of templates contains the header for Norwegian was gone, I think they lost their instance. They are why they disappear. If you see Templates(since header are build with elementor). The Instance on all Norwegian is empty, but the English ones are not. It is Instances who link each to a certain page or the whole site.

July 5, 2019 at 2:33 pm #4152137

rickardR-2

hidden link

July 5, 2019 at 2:45 pm #4152231

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Rickard,

I'm not that familiar with all these templates and instances but I'm trying to keep up and check all the elements. As I can see, this is the homepage in English hidden link and this is the header used on it hidden link, am I right?. Now I'm checking the translations and see why are they not connected but I want to make sure that I'm checking the right elements. The reason why I'm asking this is that I checked this page hidden link and I could see that on the Instances column there's only Front Page
Page #12718
but no HomePage mentioned.

Thanks,
Radu

July 5, 2019 at 2:54 pm #4152263

rickardR-2

"Header n" is the header for the front page. But "Header-inner" is for the Entire Site.

The homepage is found in "Pages" under the name "home-new — Elementor". I tried to edit it(to front page), but it just showed the logo and not the rest of the header.

July 5, 2019 at 3:41 pm #4152533

rickardR-2

Did you figure it out? 🙂

Rickard

The topic ‘[Closed] Main Menu disappeared after translation’ is closed to new replies.