This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:

Submenu items in the other language are not showing the correct URL address.

Solution:

In this case, the user has manually changed the permalink of the page to be the desired URL.

Tagged: 

This topic contains 3 replies, has 2 voices.

Last updated by Itamar 1 year, 5 months ago.

Assigned support staff: Itamar.

Author Posts
May 23, 2018 at 1:23 pm #2215755

Eddie

I am trying to: have the URL show the main menu-item (ex. hidden link)

Link to a page where the issue can be seen: hidden link

I expected to see: (ex. hidden link)

Instead, I got: (ex. hidden link)

May 24, 2018 at 11:16 am #2222210

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

Thank you for contacting the WPML support forum.

I cannot see the issue on your site.
I think that it is because that the English language is hidden on your site?

Are the Dutch and English menus synced?
If not, then please try to sync them and see if the problem persists.
You can read about syncing menus in our documentation here.
https://wpml.org/documentation/getting-started-guide/translating-menus/#option-2-automatic-menu-sync-by-wpml
https://wpml.org/documentation/beginners-guide-to-site-translation/translating-menus/#automatic-menu-synchronization

Please let me know if this information is helpful to you.

Regards,
Itamar.

May 24, 2018 at 11:54 am #2222305

Eddie

Hi Itamar,
The English language was hidden, that's right. In the Menu Sync page I see, back to back, the Dutch and English named menu items. It wasn't possible though, to change the name of all the items. Some of them remained in Dutch, so did the URL of the English page, while the page itself did load in English. I found a workaround, by directly editing the English page and changing the permalink on top of the page. I did it manually for half of all the pages. Now it's OK. Maybe not the best way, but,,, OK.

May 24, 2018 at 3:42 pm #2224219

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

I'm glad that you have found a workaround for this issue.

Cheers,
Itamar.