Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 11 replies, has 2 voices.

Last updated by Waqar Ali 1 month, 2 weeks ago.

Assisted by: Waqar Ali.

Author Posts
February 6, 2024 at 2:38 pm #15272398

Tamara Kellogg

Hi there.

I just added a new page to my small website (English is primary, Spanish is secondary). Now the main menu appears in English even on the Spanish side.

I saw an old support ticket about sidebar menus, and tried to look for the ID of the main menu to enter it in string translation, but couldn't find that.

I also tried menu sync, but that hasn't worked either.

Oddly, when I go to Appearances-->menus, only one language shows up within the choose menu drop-down menu. If I've most recently been on English, then the English menus show. If I've been on Spanish, then the Spanish menus show. But not both at the same time.

Much gratitude in advance for your help!

Tamara

Screen Shot 2024-02-06 at 9.35.46 AM.png
February 7, 2024 at 8:51 am #15275164

Waqar Ali
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi Tamara,

Thank you for contacting us and I'd be happy to assist.

Are you experiencing the same behavior whether you visit the page as a non-logged-in guest or as a logged-in administrator?

If it is only happening for guests, it could be due to the cached version of the page being served and you can test it again, after clearing all involved caches.

In case the issue persists, you're welcome to share temporary admin login details, along with the exact steps to see the issue.

Note: Your next reply will be private and making a complete backup copy is recommended before sharing the access details.

regards,
Waqar

February 9, 2024 at 11:55 am #15285863

Waqar Ali
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Thank you for sharing these details, but I'm getting the incorrect password message.

Can you please check the username and password again?
(I've set the next reply as private)

February 12, 2024 at 6:39 pm #15294516

Tamara Kellogg

Hello, please excuse the delay. I tried to answer a few days ago but the option wasn't available...perhaps it was off hours? Anyway... I have checked the password and reset it. I'm however not certain this reply is private...it doesn't indicate that and I'm concerned my delay has affected this. If you can confirm that the reply will be confidential, I will answer today with the username and password.

February 14, 2024 at 8:14 am #15300376

Waqar Ali
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

No worries and I've set your next reply as private, again.

February 16, 2024 at 1:07 pm #15311751

Waqar Ali
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

The new access details worked, thank you.

During troubleshooting, I noticed that the 'Main Menu' was translated into 'Spanish', but it was not linked with the English version of the menu.

As explained in the last step of the following guide, I linked the Spanish translation of the menu to its English version and the menus are now showing correctly in both languages:
https://wpml.org/documentation/getting-started-guide/translating-menus/#fully-custom-create-menus-manually

February 16, 2024 at 9:08 pm #15313156

Tamara Kellogg

Thank you dearly for fixing the problem so the site performs correctly!

I am confused, however, as to how you did this, since the guide you linked to shows windows that do not look like what I see when I click on Appearances-->menus.

I do not have any option to "+" a menu in another language. The Spanish menus are not available to me in the drop-down menu under "select a menu to edit." I do not see where to link them (I looked for all of this before creating this ticket).

Might you know why I am not seeing what the guide shows? How can I fix this myself in the future?

Screen Shot 2024-02-16 at 4.03.02 PM.png
February 20, 2024 at 10:40 am #15321833

Waqar Ali
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Thanks for the update and glad that I could help.

As shown in the attached screenshot, I went to WP Admin -> Appearance -> Menus, switched to Spanish language and then selected the menu 'Main Menu (Primary English)' as the translation of the menu 'Main Menu (primary Spanish)'.

If you're not seeing the translation related options on the 'Menus' screen, it is most likely that you're logged in as user who doesn't have the translation capabilities.

Have you tested logging is as the test admin user that you've shared with me?

screenshot-nav-menu.png
February 23, 2024 at 12:51 am #15335928

Tamara Kellogg

Well, it seems that my browser is not displaying the page correctly. See attached screenshot of the WordPress window in Firefox. This absence of the Spanish link on the left is the same when logging in as my original user, or as the user I created for you.

In Chrome (second, more oblong screenshot), I can see the Spanish option on the left, but the drop-down menus on the right are overlapping. The zoom is 100%, and this misalignment doesn't change if I zoom out to give the WordPress page more space.

My WordPress should be updating automatically, so not sure why this would occur in both browsers.

Screen Shot 2024-02-22 at 7.49.02 PM.png
Screen Shot 2024-02-22 at 7.44.40 PM.png
February 26, 2024 at 10:53 am #15343584

Waqar Ali
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

The fix for this navigation menu's layout issue was included in the WPML release 4.6.8.
( ref: https://wpml.org/errata/wpml-4-6-7-backend-navigation-menu-layout-issue-with-wordpress-6-4/ )

Your website is using an older version of the WPML plugin (3.9.4). Please update all plugins to the latest version and this screen's layout will be fixed.

February 28, 2024 at 6:55 pm #15355578

Tamara Kellogg

Thank you for this! I have updated WPML, and it fixed the issue with Chrome, but not Firefox. Please see attached screen shots.

No need to continue to troubleshoot this, as my primary issue (the translation of the main menu) has been fixed. But figure you might want to know in case WPML might want to investigate further.

Thank you much for fixing my menus!

Screen Shot 2024-02-28 at 1.42.57 PM.png
Screen Shot 2024-02-28 at 1.41.13 PM.png
February 29, 2024 at 9:03 am #15356788

Waqar Ali
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Thanks for the update and glad that it was fixed.

Looking into the screenshots, I understand that you're using two different-level users in both browsers.

I'll recommend testing with the Firefox with the same user as Chrome and if the issue persists, you're welcome to start a new ticket.

This ticket is now closed. If you're a WPML client and need related help, please open a new support ticket.