This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: Is there a way to make a post that I create, by default not translatable ?

Solution: You can achieve it by selecting ‘Not translatable’ for posts post type from WPML >> Settings > Post Types Translation as you can see in attached screenshot. https://cdn.wpml.org/wp-content/uploads/2019/03/3319201-not_translatable.jpg?x81497

0% of people find this useful.

This topic contains 3 replies, has 3 voices.

Last updated by Tommaso 7 months, 1 week ago.

Assigned support staff: Noman.

Author Posts
March 11, 2019 at 10:26 pm #3316961

vasilikiK

Hello,

Is there a way to make a post that i create by default not translatable ?

Thank you

March 12, 2019 at 8:25 am #3319201

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,
Thank you for contacting WPML Support. You can achieve it by selecting ‘Not translatable’ for posts post type from WPML >> Settings > Post Types Translation as you can see in attached screenshot.

Thank you

March 12, 2019 at 9:36 am #3320223

vasilikiK

My issue is resolved now. Thank you!

May 17, 2019 at 2:25 pm #3835237

Tommaso

Hi @noman

I wanted to make posts not translatable and keep them only in the main language (Italian). I perform the following steps:

- I select "Not translatable"
- Create a new post (post_1)
- In template home.php, post_1 is not displayed
- Select "Translatable - only show translated items"
- In template home.php, post_1 is displayed
- I select "Not translatable"
- In template home.php, post_1 is displayed
- Create a new post (post_2)
- In template home.php, post_1 is displayed, post_2 is not displayed
- Select "Translatable - only show translated items"
- Inside the template home.php, post_1 and post_2 both are displayed

If posts are created "Not translatable" they are not inserted into the variable $posts unless they are made translatable and then again not translatable. This is definitely a bug.