Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 19 replies, has 2 voices.

Last updated by Bigul 1 week, 5 days ago.

Assigned support staff: Bigul.

Author Posts
September 12, 2020 at 5:07 pm #6999765

thibaultd-4

I searched in all settings but didn’t find a way to enable translatability and duplication of Elementor Templates.
Everything works fin on pages and works fine with Elementor builder active, but Elementor templates don’t seem to benefit of the same settings.

did I miss something ?

September 14, 2020 at 7:14 pm #7012731

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve the issue.

Please visit WPML>>Settings>>Post Types Translation section, the Elementor template will be set as *Translatable - use translation if available or fallback to default language* by default with a lock sign via WPML Language configuration file(for example like Media & Blocks translation settings set by WPML). Most probably you can find the language configuration file(wpml-config.xml) in the root folder of Elemeter Pro. Please check the attached images and the following documentation for more details.

https://wpml.org/documentation/support/language-configuration-files/

https://wpml.org/documentation/translating-your-contents/displaying-untranslated-content-on-pages-in-secondary-languages/

If you are still having the issues, please let me know the exact steps to replicate the Elementor Template sync issue on your site. It will be great if you can share a couple of screenshots for a better understanding of the template conflicts.

--
Thanks!

Bigul

September 15, 2020 at 9:20 am #7016373

thibaultd-4

I added this line to the XML file :

<custom-type translate="1">elementor_library</custom-type>

but nothing changed. I also did most of the cleanup actions in advanced operations.

So I now removed the snippet and still have the issue.

NB: Are you sure that Elementor Templates have that capability. I don't see why it wouldn't but the question remain as I see the same issue on all sites.

September 15, 2020 at 5:23 pm #7020199

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the feedback. I have a couple of requests for tracking the issue.

a) Please fill the private details fields after a full site backup. I would like to access the admin area of your site for further checking.

Please refer to the following links for more details about our private information sharing policies.

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

hidden link

b) Please let me know the steps to replicate the issue facing on your site because of this setting for Elementor Templates

--
Thanks!

Bigul

September 16, 2020 at 11:25 am #7026487

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the details and login information. I was able to change the translation preference of *My Templates(elementor_library)* after the following steps.

1) Go to WPML>>Setings
2) Choose *Custom XML configuration* tab
3) Add the following language configuration code in *Custom XML configuration* field and save the changes

<wpml-config>
    <custom-types>
        <custom-type translate="1">elementor_library</custom-type>
    </custom-types>
</wpml-config>

Please check the attached images and the following documentation for more details.

https://wpml.org/documentation/support/language-configuration-files/#custom-types

https://wpml.org/documentation/support/language-configuration-files/overriding-language-configuration-files/

We have set *Translatable - use translation if available or fallback to default language* translation preference for *My Templates(elementor_library)* because it will help the users to get the template in the secondary languages without translation or content duplication. Please check this article for more details - https://wpml.org/documentation/translating-your-contents/displaying-untranslated-content-on-pages-in-secondary-languages/

--
Thanks!

Bigul

September 17, 2020 at 12:29 pm #7036605

thibaultd-4

Thanks for the tip Bigul, it seem to work fine.

Now, since it's an essential part of a website building workflow, is it possible to manage with Elementor to include this feature by enabling the checkboxes for that kind of post type as displayed previously ?
Adding your snippet works for sure and should probably give reliable solution, but
- "what if" Elementor implement what I suggest ? Will it conflict with this code ?

- I would rather prefer that it's fixed with them right away and avoiding using such snippets - that can be easily forgotten.

Waiting for your best suggestions for a smooth workflow.

Regards.

September 17, 2020 at 5:08 pm #7039373

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the feedback. Normally it will not be an issue while changing the translation preference of a Post Type from *Translatable - use translation if available or fallback to default language* to *Translatable - only show translated items*. But we have to translate or duplicate the Post or Post template(in the case of Elementor template) to list it on the secondary languages.

Please check the attached image. We can change the translation preference of Post Type or Taxonomy set via wpml-config.xml by unlocking it. To do so please try the following steps after a full site backup.

1) Go to WPML>>Settings>>Custom XML configuration
2) Clear the current language configuration code and save the changes
3) Go to WPML>>Settings and scroll down to *Post Types Translation* section
4) Click on the Lock icon of *My Templates (elementor_library)* to unlock
5) Change the translation option and save the settings
6) Reload the page(browser reload) to refresh the translation settings

--
Thanks!

Bigul

September 18, 2020 at 1:28 pm #7046131

thibaultd-4

That's ok, I already understood and applied everything.
My request is making this a default setup within Elementor : "we have to translate or duplicate the Post or Post template(in the case of Elementor template) to list it on the secondary languages."
Can you handle this with them for best compatibility. Read my last comment for more detailed question.

September 18, 2020 at 6:18 pm #7048185

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. I am consulting about this with our compatibility team now. We will get back to you as early as possible. Please wait.

--
Thanks!

Bigul

September 21, 2020 at 7:59 am #7056851

thibaultd-4

Should I answer to this message each time to keep the ticket open ? : If you don’t add a message, we’ll assume that the problem is resolved and close this thread.

September 21, 2020 at 10:11 am #7058143

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

I have shared the details with our compatibility team and waiting for their feedback now. We will get back to you as early as possible.

The ticket will be closed automatically only if there no response for two weeks and the ticket is not escalated to our team. So please ignore this notification. It is only an alert by our support systems.

--
Thanks!

Bigul

September 22, 2020 at 3:10 pm #7071153

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

For your kind updates, by default we have set the translation preference for the My Templates (elementor_library) post type as Translatable - use translation if available or fallback to default language by default because of the following reason. We have implemented these settings since WPML 4.0.8 version.

a) It is an easy solution for the compatibility between WPML and Elementor

b) When an untranslated global widget is included in a page, Elementor Editor will not open in the secondary languages

c) The template will be available in the secondary languages without translation or content duplication

Therefore we can only change the translation preference by the following steps. Thank you for your understanding.

a) Adding WPML language configuration code in WPML>>Settings>>Custom XML configuration

or

b) Unlock the Locks icon of *My Templates (elementor_library)* from WPML>>Settings>>Post Types Translation section, then change the translation option and save the settings - https://wpml.org/wp-content/uploads/2020/09/7039373-2020_09_17_22_30_11.png

--
Thanks!

Bigul

September 24, 2020 at 12:33 pm #7091073

thibaultd-4

Thanks for the update. Let me notice that as you stated :
"
b) When an untranslated global widget is included in a page, Elementor Editor will not open in the secondary languages
"
Well this behaviour is the kind of choice that the developer should have, and is exactly what I wanted to change to be able to "duplicate" so that everything works fine during development stage - contrary to what you stated at :
"
a) It is an easy solution for the compatibility between WPML and Elementor
"

Therefor I still ask to update the Elementor compatibility to allow duplication capability by default for templates.
Keep in mind that allowing this wouldn't make duplicates a default since the developer has to manually chose which post to duplicate. Because of that I see only good reasons to not implement it as described.

Let me know what your compatibility teem says.

September 24, 2020 at 7:05 pm #7094003

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the feedback. I have shared it with our compatibility team and waiting for their expert opinion now. We will get back to you soon. Please wait.

--
Thanks!

Bigul

September 30, 2020 at 10:26 am #7133147

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

We have a workaround for this issue. Please try the following steps after a backup and make sure you are getting the expected result or not. Refer to the attached image for more details.

1) Go to WPML>>Translation Management Dashboard
2) Choose *Template* option for the Post Types
3) Filter with *Not translated or needs updating* translation status
4) Choose the templates wants to duplicate
5) Select *Duplicate content* option
6) Duplicate the template to secondary language

--
Thanks!

Bigul