This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Rohan Sadanandan 1 month ago.

Assigned support staff: Rohan Sadanandan.

Author Posts
September 17, 2019 at 12:59 pm #4588639

ivanT-23

Hi,

so I just bought WPML, i'm used to qtranslator, so I'am having a hard time. But there is more of all one thing, how may I do that if an article or page does not has a transaltion, users see the "orginal" / primary language?

thanks

September 18, 2019 at 9:56 am #4594707

Rohan Sadanandan
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for contacting WPML Support.

Please navigate to WPML > Settings > Post Types Translation and set the post type to "Translatable - use translation if available or fallback to default language"

You can read more about this in the documentation:
https://wpml.org/documentation/translating-your-contents/displaying-untranslated-content-on-pages-in-secondary-languages/

If you need to do this for only a single page, just edit the page & select "Make 'Pages' appear as translated" under Multilingual Content Setup.

Also, I request you to update the WP Memory Limit to at least 128MB which is the minimum requirement for WPML: https://wpml.org/home/minimum-requirements/
Add this code to your wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

Paste it just before:

/* That's all, stop editing! Happy publishing. */

Thanks,
Rohan