This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by Noman 3 weeks, 1 day ago.

Assigned support staff: Noman.

Author Posts
September 24, 2019 at 7:19 pm #4633855

robertH-40

I am trying to: Translate a menu

Link to a page where the issue can be seen: Appearances > Menus

I expected to see: A way to switch between languages as shown in the examples

Instead, I got: Nothing.

I have tried updating plugins and core, deactivating all plugins, setting to a default theme, etc

On the front end, I see the same menu across all of my translations.

September 25, 2019 at 5:20 am #4635681

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support.

=== Please backup your database and website ===

1. Please upgrade your server’s PHP version to a higher level: https://wpml.org/home/minimum-requirements/

- PHP is 5.6.35 which is good, but it's advised is to use more up-to-date version for better performance and stability. You can contact your website hosting company to upgrade this for you.

2. If still issue persists, please enable error reporting at you site as I need to see the details of the error log. You can see how to enable debug logging here:
https://wpml.org/documentation/support/debugging-wpml/
https://codex.wordpress.org/Debugging_in_WordPress

To enable it, open your ‘wp-config.php’ file and look for ‘define(‘WP_DEBUG’, false);’. Change it to:

// Enable WP_DEBUG mode
define( 'WP_DEBUG', true );

// Enable Debug logging to the /wp-content/debug.log file
define( 'WP_DEBUG_LOG', true );

// Disable display of errors and warnings 
define( 'WP_DEBUG_DISPLAY', false );
@ini_set( 'display_errors', 0 );

define( 'SCRIPT_DEBUG', true );

After adding the above code please go to Appearance >> Menus page and this will create debug.log file in your site's wp-content directory. Please send me its contents.

Thank you

September 25, 2019 at 3:08 pm #4640259

robertH-40

The issue appeared to be with my browser (firefox). A clean install of WordPress and clean install of WPML with no other plugins and on the 2019 theme still showed the same issue. The option to select which language a menu is was not showing. I switched to Chrome and the issue was resolved. So I guess a take away can be maybe to have the developers test firefox a bit more?

September 25, 2019 at 4:18 pm #4641077

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

I have checked in Firefox browser with fresh WP and WPML installation and it’s working fine for me. It might be your Firefox browser cache issue.

Thank you

The topic ‘[Closed] Manual Menu Translation Not an Option in Dashboard’ is closed to new replies.