This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by Itamar 4 months ago.

Assigned support staff: Itamar.

Author Posts
May 14, 2019 at 2:30 pm #3808247

jenniferH-13

I am trying to: view a product page, switch to a currency for while I have not manually defined a price, and view that price automatically converted via Currency Layer.

Link to a page where the issue can be seen: hidden link

I expected to see: when I switch to AUD I expect to see a converted price since it was left blank in the product configuration on in WordPress

Instead, I got: no price was returned and there is a javascript error in this file: hidden link

May 14, 2019 at 5:07 pm #3809371

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

I can see the problem on the link that you share with me. If I use the currency switcher and switch the currency, all the prices show. But no price shows when I switch to the AUD.
You wrote: "when I switch to AUD I expect to see a converted price since it was left blank in the product configuration on in WordPress"
I'm not sure exactly where you have left the price blank.
Could you explain that, please?
Does on the product editing screens you have selected 'Set prices in other currencies manually' and there left the price for AUD blank? Please see the attached screenshot.

Thanks,
Itamar.

May 14, 2019 at 6:55 pm #3810037

jenniferH-13

That is correct. The USD value is set. A couple of other values are set. But the AUD value is empty, and the message above the text box states, "Determined automatically based on exchange rate," for the AUD field, so we expect that value to be converted on the front end. Thanks.

May 15, 2019 at 2:56 pm #3818065

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi and thanks for the extra details.

I can replicate this issue on a fresh WordPress installation. I replicated this issue also for the manually set exchange rate and didn't even use the Automatic Exchange Rate. Therefore I've escalated this issue to our second tier supporter, and they will check it.

We'll keep you updated here.

Thank you for your patience.
Itamar.

May 21, 2019 at 8:00 pm #3858695

jenniferH-13

Is there any update here? This issue is causing a javascript error on the front-end as well.

May 21, 2019 at 10:41 pm #3858975

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

I'm sorry, but still, I don't have an update for you on this matter.
My only suggestion for you at the moment is to set those prices manually.
I'll keep you updated here.

Regards,
Itamar.

June 16, 2019 at 5:31 am #4029755

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

Our developer informs me that this fix is already included in WCML 4.6.5 which was recently released.
Could you please update WPML and its add-ons to their latest versions and see if the issue is solved on your site?

Thanks,
Itamar.