This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 6.48 hours from now. Thank you for your understanding.

This topic contains 2 replies, has 2 voices.

Last updated by maryS-2 1 year ago.

Assigned support staff: Ricardo Alday.

Author Posts
October 1, 2018 at 3:18 pm #2778597

maryS-2

Hi guys, i have a question about a change setting made from my customer.
The languages were setting in this way: domain.it/en; domain.it/es etc...Last month my customer change wpml settings and now i have "domain.it/?lang=en"; "domain.it/?lang=es" etc..
Now i have a lot of 404. There is a way to set wpml to automatic redirect language from "/en" to" /?lang=en" or i have to manual redirect all url?

Looking forward hearing from you.
Best regards
Ms

October 3, 2018 at 12:22 am #2783021

Ricardo Alday

Hi,

WPML should change that automatically just flush your permalink settings.
To do that, go to WP dashboard -> Settings -> Permalinks and hit the "Save changes" button a couple of times.

Hope that helps,
Ricardo

October 3, 2018 at 8:34 am #2783939

maryS-2

My issue is resolved now. Thank you!