This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: I'm trying to manually translate pages but I don't get the option when turning off the translation option in the page, screenshot: https://cdn.wpml.org/wp-content/uploads/2019/04/3701339-Screen_Shot_2019_04_29_at_11.54.04.png?x34514

Solution: - I have logged in to your site and created a new page as ‘Test Page’ and switched off ‘Use WPML's Translation Editor’ and added translation using manual translation mode without any issue.

- If you want to use manual translation for existing pages then you need to add translation again, you can duplicate original page and then you can add translation manually.

The reason is that the manual translations are saved in the wp_posts table while the Translation Editor translations are saved as String packages.

This is why when you use one method for translation, you can't see the translations on the other method.

Relevant Documentation: https://wpml.org/documentation/translating-your-contents/displaying-untranslated-content-on-pages-in-secondary-languages/using-content-duplication/

This topic contains 8 replies, has 3 voices.

Last updated by Marko Polo 5 months, 1 week ago.

Assigned support staff: Noman.

Author Posts
April 29, 2019 at 8:56 am #3701339

hananM-3

Tell us what you are trying to do?
I'm trying to manually translate pages but I don't get the option when turning off the translation option in the page
Is there any documentation that you are following?
yes
Is there a similar example that we can see?

What is the link to your site?
hidden link

April 29, 2019 at 9:25 am #3701565

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML support.

- We have released updated version of WPML plugins. Can you please take a backup of your site and update ALL WPML plugins and check if it helps?

- Please delete all sort of caches on your site / server cache (if any) / plugin cache (WP Rocket Cache) / CDN cache (if any), clear browser cache and then check the page.

- If still issue persists, please check for a possible theme and plugin conflict. To do that you can switch back to any default theme (e.g. Twenty Seventeen theme), Disable all plugins except WPML and see if this issue goes away with default theme and only WPML activated?

Thank you

April 29, 2019 at 10:42 am #3702207

hananM-3

Hey!

I did that and updated the plugins.
I didn't mention that I'm using Elementor as a builder.
still the same result.

April 29, 2019 at 3:04 pm #3704781

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

To take a closer look on this issue, please provide temporary access (WP-Admin and FTP Login info) to your site (preferably staging site), so that I can look into your setup and debug the issue.

Your next answer will be private which means only you and I have access to it.

=== Please backup your database and website ===

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

Thank you

May 2, 2019 at 8:32 am #3722727

hananM-3

Hey!
Did you manage to connect? any news?
I need to solve it ASAP

Thank you!

May 2, 2019 at 8:34 am #3722737

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

I was off yesterday due to Labor day. I will reply you today asap.

Thanks

May 2, 2019 at 10:18 am #3723713

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

- I have logged in to your site and created a new page as ‘Test Page’ and switched off ‘Use WPML's Translation Editor’ and added translation using manual translation mode without any issue.

- If you want to use manual translation for existing pages then you need to add translation again, you can duplicate original page and then you can add translation manually.

The reason is that the manual translations are saved in the wp_posts table while the Translation Editor translations are saved as String packages.

This is why when you use one method for translation, you can't see the translations on the other method.

- If you still found any issue in turning ON manual translation for existing pages then please follow this procedure:

1. Open page in edit mode and turn ON ‘Use WPML's Translation Editor’ radio button, if it’s off.
2. Select ‘This page’ from popup.
3. Press Okay button

4. Then please turn OFF ‘Use WPML's Translation Editor’
5. Select This Page
6. Press Okay

I hope now you can add translation using manual translation method.

Here is doc for more details:
https://wpml.org/documentation/translating-your-contents/displaying-untranslated-content-on-pages-in-secondary-languages/using-content-duplication/

Thank you

May 10, 2019 at 10:37 am #3783349

hananM-3

My issue is resolved now. Thank you!!

September 28, 2019 at 3:58 am #4657795
Marko Polo

I tried the wpml translator and now want to turn it off and translate like I used to. How do I turn the gears off?

New threads created by Noman and linked to this one are listed below:

https://wpml.org/forums/topic/i-want-to-turn-off-translation-editor/