This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Author Posts
September 23, 2019 at 9:32 pm #4626685

Ryan Wild

Hi, I noticed that the transfer of old translations to the new advanced translator is extremely bad. On the homepage, most went through. But on the products page, only 1% of the old translations made it through. That's not very good. We spent a lot of time and money translating these pages for them to not work now. What should I do? Should I revert back to the old system and forget about the new translation editor?

September 24, 2019 at 6:17 pm #4633435

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for contacting the WPML Support Forum.

May I ask what you mean with "went through"?

Do you mean that the Advanced Translation Editor does not open for product pages?

Before taking any further steps please make sure to adjust the wp-memory limit, as the current configuration does not meet the minimum requirements to run WPML.

Could you please increase your WP Memory limit to 256M? 128M is the minimum required by WPML.
Your current values are:

PHP MemoryLimit 512M
WP Memory Limit 40M
Add this code to your wp-config.php to increase WP memory:

/* Memory Limit /
define('WP_MEMORY_LIMIT', '256M');

Paste it just before:

/ That's all, stop editing! Happy blogging. /

These settings can be limited directly by your hosting provider, so I recommend you to contact and ask them to modify them directly.
If you can get even higher values It would be great.

https://wpml.org/home/minimum-requirements/
Note: WPML needs a minimum WP Memory limit of 128M to work only under a minimal environment, it means, with a default theme and no other plugins installed.

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

IMPORTANT

Please make a backup of site files and database before providing us access.
If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

Kind regards
Andreas

September 25, 2019 at 5:46 pm #4641569

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you very much for the detailed information.

I can see that you enabled the ATE (Advanced Translation Editor) for all translations, which also includes such translation that previously been translated with CTE (Classic Translation Editor).

As mentioned on our WPML -> Settings -> How to translate posts and pages section such setting can cause translations to be unusable. We usually would advise in such case to activate ATE only for newly created pages and leave old pages on CTE setting.

Please provide me some more information.

I can see the site has 530 pages, from that 498 in English and 32 translated to Spanish.

How many pages have been translated earlier before switching to ATE?

Do you still have a database backup from the point before switching to ATE available?

I think in such case there is possibly not more we can do than trying to import the translation form an earlier state of the site but I will consult our second-tier support once I received your feedback.

Kind regards
Andreas

September 28, 2019 at 2:29 pm #4658471

Ryan Wild

Hi Andreas,

The site has 530 pages, but most of those don't need translation. Spanish is only needed on about 40-50 of them. I just have a few more to go.

I do have a backup of the site from before activating ATE. However, this site changes so fast that I can't really restore the site to such an old backup.

I'm Ok sticking with the CTE then if the ATE is not going to import my previous translations. However, if I switch back am I going to lose my work? I have only fully translated one page to ATE, so I don't mind going back to CTE and sticking with that.

September 29, 2019 at 2:01 am #4659507

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello!

My apologies for the delay in answering.

I would advise you to make first a backup of your site and database.

What you could to now is, activate the Advanced Translation Editor but leave the setting for already translated content on Classic Translation Editor. Like this older content should open with the Classic Editor while new translation will be created with the Advanced Editor.

You will find both settings at WPML -> Languages -> How to translate posts and pages.

If you switch both settings back to Classic Translation Editor it could cause loss of those translations that have been created with the Advanced Translation Editor only. Anyhow, make sure to have the backup ready, as I did not test this myself yet.

I hope this answered your question and solved the issue for now.

Kind regards
Andreas

September 30, 2019 at 12:56 am #4661711

Ryan Wild

Hi Andreas,

I've gone with that approach. Enabled the ATE for newer pages and CTE for the established ones. Seems to be working, but I'll find out some more as I continue editing translations.

I've also upped WordPress memory limit to 256Mb. Staging doesn't reflect that yet as the current staging site is about 1 hour old. When you see this it might have been updated. I'm still working on it. Staging credentials are the same as I sent you.

I do have one request. Please look at this page:

hidden link (There is a version of it in staging)..

hidden link (Same firewall password as before).

This page is newer and was created and translated AFTER I had enabled the ATE a few weeks ago. However, the Spanish translation ONLY displays when I'm logged in. For non-logged in users, the Spanish option doesn't even appear in the menu. Also, when logged in, the Spanish version of the page appears with a URL ID, like this: hidden link instead of using the correct pretty permalink for Spanish. I've tried everything I can think of and it will just not work. To confuse me even more, if I paste that PAGE ID URL to a browser that's not logged into the site, it returns a 404.

I just tested to see that staging is doing the same thing. And it is, with the only difference that is actually shows the Spanish button option, but then when clicked, turns out a 404.

I've cleared cache, updated ALL plugins, updated the framework, resaved permalinks, resaved the page, updated the translation like 10 times, but nothing changes.

Please advise. Thanks,
Danny

September 30, 2019 at 11:34 pm #4667753

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for the message. For now, old pages should work using CTE. If you experience any issues please reach out again.

Now, for the page Motorosports I opened the Translation Editor again. It was opened with the Classic Translation Editor, therefore it seems the site was earlier translated with the CTE in the first place, could this be?
On the CTE one field called "Translation Priorities" was translated, which it should not be by default. I changed the field and applied the translation.

The Spanish language option is now available on:
hidden link

The URL was still showing up as page ID. The reason for this is that the page is still saved as Draft. You will need to change the page status to published and the permalink should show up as expected.

Let me know if you do have any further questions.

Kind regards
Andreas

October 1, 2019 at 6:27 pm #4674681

Ryan Wild

Hi Andreas,

I followed those same steps over on the production site and it worked. I don't remember ever having to go into the actual translated's page back end and having to publish Spanish independently from the English page. Maybe this is something that happened because of the discrepancies between CTE and ATE. Yeah, it's possible I translated this page first in CTE. I just don't remember. Either way, it's on CTE now and it's working, so I'll leave it.

Thanks. I think that sorts out the bulk of my problems. I'll continue working through translations and if I run into anymore problems I'll ask, but I think this sorts things out for the time being. Thank you very much.

Regards,
Danny

October 1, 2019 at 11:32 pm #4675667

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi Danny,

I am sorry about the inconveniences but I am glad to hear that the issue seems solved now.

Please reach out if something unexpected occurs. Only make sure to leave the config for the translation editors as it is, for now.

Kind regards
Andreas