This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 30 replies, has 2 voices.

Last updated by yao-yuT 1 week, 3 days ago.

Assigned support staff: Raja Mohammed.

Author Posts
October 2, 2019 at 11:52 pm

yao-yuT

I am trying to:

Display all my products properlly as before using WPML.

Link to a page where the issue can be seen:

hidden link

I expected to see:

All my uploaded images before download and activating WPML.

Instead, I got:

a lot a lot tons of ? images.

October 3, 2019 at 9:26 am #4686279

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello Yao,

I will help you with this issue as well 🙂

The media uploaded before WPML will not have any language information to fix this, Goto WPML > Settings > Media Translation, Select only option "Set media languages" (Ignore if this is not selectable) and "Translate existing media in all languages" click start. This should resolve the issue.

Let me know if that helps

October 3, 2019 at 9:32 am #4686379

yao-yuT

Will try also later on today, thanks alot for ur help again, wanted to let u know I really appreciate it.

may u have a good day!

October 3, 2019 at 9:37 am #4686509

yao-yuT

After following ur steps checking the box u gave and press start, images still remain ? in the media library, please let me know if there's any further instructions to solve this issue, thank u!

October 3, 2019 at 12:21 pm #4687493

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

I can see from the site that the images are returning 404 error which means the images are not present at the location, please let me know the results if you disable WPML do you see any change?

October 3, 2019 at 12:44 pm #4687711

yao-yuT

After deactivate WPML related plugins ( including Woocommerce multi language ), all my images in media library came back to how it was, displaying normally.

October 3, 2019 at 12:45 pm #4687719

yao-yuT

Nope, actually only a part of the images turned back to how it was suppose to be.

October 4, 2019 at 4:28 am #4692719

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Please share temporary access to your site, I have enabled private fields to securely share the details.

October 4, 2019 at 6:03 am
October 4, 2019 at 11:04 am #4695033

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

The media images are available under the English language, I think you have changed the default language of the site from English to Chinese and this is causing some issues for you. To fix the media issue.

Goto WPML > Settings > Media translation
Select the option
[x] Duplicate existing media for translated content
[x] Duplicate the featured images for translated content
- Click start

[x] Duplicate media attachments for translations
[x] Duplicate featured images for translations
- Click Apply

This will make sure the media is available throughout all the languages.

October 4, 2019 at 11:31 am #4695261

yao-yuT

All my images still remain ? Even in the English language, I think it’s some bug causing because of WPML, please check the media library and have a look for all languages to see the problem, and please lemme know if there’s any further steps to follow, thank u!

October 4, 2019 at 2:24 pm #4696455

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

I have run the same troubleshooting steps, I am able to see the media files in the Chinese language as well. Please check the attached screenshot. Kindly verify the same.

October 4, 2019 at 3:53 pm #4697159

yao-yuT

My friend didnt u see pop h and silk in picture still missing...? it happens on tons of medias...
it's not working after following ur steps, bug still remains, all the images used to display properly before activating WPML.

October 5, 2019 at 3:47 pm #4700771

yao-yuT

Anyone support staff technique helping?

October 6, 2019 at 6:19 am #4701733

yao-yuT

Still waiting for help.