This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 13 replies, has 3 voices.

Last updated by sarah.n 6 years, 1 month ago.

Assigned support staff: sarah.n.

Author Posts
July 18, 2013 at 8:42 am #146137

Amir
Supporter

Do your media file fail to duplicate or are some or all your media files hidden in the Media library?

Our developers are addressing this and other 2.9 issues as we speak in order to release 2.9.1 as soon as possible.

Thank you for your patience!

July 21, 2013 at 8:56 pm #147032

Antonio

Any news on the update? Its been quite a long time considering this is a commercial product.

July 22, 2013 at 1:19 am #147046

Amir
Supporter

Yes, we have an update. We've identified the source of the problem and are fixing it. We'll have a new version of the Media Translation plugin this week. It includes an updated GUI, which explains a lot better what the plugin does. It also fixed the problems reported here. The new version is in final debug now and will go into QA tomorrow.

July 22, 2013 at 1:37 am #147048

Antonio

Hi Amir,
I actually removed the media translation plugin and downgraded to 2.8.2 but the wordpress galleries are still not showing.

Any Help?

July 22, 2013 at 1:49 am #147049

Amir
Supporter

Without the Media Translation plugin, WPML does not filter your media files. I suspect that you've accidentally (when trying to sort out other things) made the 'Media' items translatable. This may lead to such results.

To change it back:
1. Go to the Media library and click to edit any media item
2. Scroll to the bottom, where it says 'Multilingual Content Setup'
3. Make sure that the checkbox for "Make 'Media' translatable" is not selected

July 22, 2013 at 1:59 am #147051

Antonio

Unfortunately, the checkbox in not selected.
It simply does not show the galleries, it does show single images and images inserted in custom metaboxes.
In the_content text area the gallery appears but if I click on edit gallery the media uploader is empty and on the front-end there are no images. The Default Language works the translations have this problem.

Do you have any idea regarding what could cause the issue and how to resolve it?

July 22, 2013 at 2:49 am #147053

Amir
Supporter

It's really difficult to tell without understanding the full scenario.

How about we do this:
- Create a new support thread, explaining what you have. If you look at our communication here, you see that we don't have a description of what you are doing and the problem you're having.
- Mihai will be ready with an update for the Media Translation plugin today. He will send you that update, with WPML update and you can install it and check.
- If you are still having any trouble, we'll need login details to your site, so that we can see it happening too.

We'll make sure that everything is working for you and clear before we release an update. However, to do that, we need to exactly understand what the problem is and we also need a little time to complete the upcoming change and test it on your site.

Would that be OK?

July 22, 2013 at 3:20 am #147055

Antonio

Hi Amir,

Thank you for your kind reply.

I actually did open a new support thread few hours ago but I did not receive any reply.
Your solution sounds great to me, I'll be waiting for the update.

Thank you v

July 22, 2013 at 5:48 am #147064

sarah.n
Supporter

Languages: English (English ) German (Deutsch )

@antonio,

I have just replied to your open forum thread: http://wpml.org/forums/topic/galleries-do-not-display-in-translations/#post-147063

Would you kindly provide a reply over there so we can assist you further?

This is in order, as Amir mentions above, to ensure that the fixes our developers are putting into the WPML Media plugin will truly fix your problem. This will not happen if we are talking about different issues.

Thank you!

July 22, 2013 at 5:55 am #147074

Antonio

Hi Sarah,

My apology for my late reply, I was replying Amir's post, I've copied and pasted the required array.

Thank you

July 22, 2013 at 6:01 am #147078

sarah.n
Supporter

Languages: English (English ) German (Deutsch )

No worries! Lets take this conversation now over there in the other forum thread shall we? 🙂

July 24, 2013 at 7:19 am #148072

sarah.n
Supporter

Languages: English (English ) German (Deutsch )

Version 2.9.1 has just been released: http://wpml.org/2013/07/wpml-2-9-1-bugfix-release/

July 24, 2013 at 7:27 am #148077

Antonio

Thank you very much for the update Sarah.

July 24, 2013 at 11:14 am #148187

sarah.n
Supporter

Languages: English (English ) German (Deutsch )

You are welcome!