This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by Diego Pereira 6 months, 2 weeks ago.

Assigned support staff: Diego Pereira.

Author Posts
March 27, 2019 at 8:42 am #3468679

Pontus

I am trying to:

Media Library. It is very hard to handle images. Seems like Media Translation makes it up.
We have previously only had to upload pictures / pdf's once and so they have been available in both languages.

Now, lots of pictures have disappeared from the library on the English page and some published English pages are displayed without pictures.

It is also not possible to delete pictures from the Swedish media library, which is very concise, they just come back again.

It also poses a problem that one cannot delete a picture permanently and then upload a new one with the same file name without it being a new version.

Our pictures on the pens that are saved with part number and code (type 505008400-M.jpg) must be so hot that it will be visible in the pen selector but if we need to replace it a version is created (type 505008400-M-2) and then it cannot be found in the pen selector.

Link to a page where the issue can be seen:

I expected to see:

Instead, I got:

March 27, 2019 at 9:45 am #3469189

Pontus

I still need assistance in this. Please let me know if i can provide you with more helpful information.

March 27, 2019 at 2:24 pm #3471919

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello @pontus, welcome to the WPML support Forum!

Please go to WPML > Settings > Media Translation, select all boxes then click on "Start" to run the media scan. (See screenshot).

After that, please check all boxes and click on "Apply".

Please let me know if it worked for you or if the issue still occurs after these steps.

All the best,
Diego

March 27, 2019 at 11:14 pm #3476091

Pontus

There still not showing up in the right library. Is there any way to set the WPML translation to pass forward the media category as well?

They got the right category before.

And about the other questions, why is it not possible to delite the pictures?

Thanks!

March 28, 2019 at 4:50 pm #3484113

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

I sent some instructions to replicate the website through a private message (previous answer).

Please let me know if it worked for you. If so, please send us clear instructions on how to see/reproduce the issue.

Kind regards,
Diego

March 29, 2019 at 2:09 pm #3491999

Pontus

Okej so now the migration is upp and running.

The problem out client have is that the handling of media in the library have changed. Before they ony needed to upload one picture and it translated to both language, got categorised in the right category in both languages.

They also have trouble deleting pictures and files. The file just keeps popping up again. Do they have to delete them in a specifik order or is ther something els wrong?

So thankfun for your help 🙂

April 1, 2019 at 12:26 pm #3507859

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

It seems that you are using the "Enhanced Media Library" plugin on your website, which changes the behavior of how WordPress ahndle media. This seems to be a new compatibility issue with this plugin. In these cases, these are the procedures:
- Install the plugin in a clean installation and reproduce the problem in this new installation. So we can isolate it and do some testing without the interference of server settings or other plugins
- After this, I will check the problem in this new installation and look for a quick solution
- If I can not find a solution, I will forward the problem to our compatibility team
- The compatibility team will do some more testing and will contact the product author to fix the issue

I created a test website with a clean WordPress install. You can access it through this link:
hidden link - Through this link you will be automatically logged in.

Please upload the "Enhanced Media Library" plugin to this test install, setup it the same way as in your website (using the same options) and create some dummy content to reproduce the issue and check if the same issue of your website occurs on this clean installation. Please note that we only need the plugin and the related functionality, you don't need to setup a entire website or clone your existing site.

After that, please send us clear steps on how to see/reproduce the issue on this test install. We will run some tests and forward to our compatibility team if needed.

Kind regards,
Diego

The topic ‘[Closed] Media files not translating to multipli language’ is closed to new replies.