This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: In every English property page, there is a gallery of photos. In the Italian property pages are showing only the main photo but not the rest of the photos in the galleries.

Solution: - Go to WPML-> Settings -> Media Translation. - For old content, check that following options are check and press Start button. This would create link to images for other languages for previous contents. X Translate existing media in all languages X Duplicate existing media for translated content X Duplicate the featured images for translated content - Click on the Start button.

Relevant Documentation: https://wpml.org/documentation/getting-started-guide/media-translation/

This topic contains 2 replies, has 2 voices.

Last updated by naomiT-2 3 months, 3 weeks ago.

Assigned support staff: Andrés.

Author Posts
July 1, 2019 at 12:49 pm

naomiT-2

In every English property page, there is a gallery of photos.
In the Italian property pages are showing only the main photo but not the rest of the photos in the galleries.

July 1, 2019 at 2:19 pm #4120103

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+02:00)

Hello there,

Welcome to WPML support forum.

I have visited your site and I have run the duplication images process at WPML-> Settings -> Media Translation. Now, if I open an italian property, it displays all the images.

Does it solve your issue?

Documentation:
https://wpml.org/documentation/getting-started-guide/media-translation/

Best regards,
Andrés

July 1, 2019 at 4:39 pm #4121189

naomiT-2

My issue is resolved now. Thank you!