This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by Ahmed Ibrahim 4 years, 1 month ago.

Assigned support staff: Ahmed Ibrahim.

Author Posts
July 29, 2015 at 6:15 pm #669484

Muriel

I am trying to:

URL of (my) website where problem appears: All websites (various domains with WordPres 4.3.2.)

I expected to see: only one image when I upload it to the media library.

Instead, I got: it show about 300 duplicates which do not work/broken/defective.

I have checked all plug-ins one by one by activating etc. Issue is WPML related. Even if I use the twentysomething theme from WP itself.
When WPML is deactivated it works fine.

Same issues like:
https://wpml.org/forums/topic/duplicate-image-over-and-over-again/
https://wpml.org/forums/topic/images-not-added-to-media-library-on-upload-when-wpml-is-active-2
https://wpml.org/forums/topic/media-library-loads-pic-3000-times/

Versions WPML:

WPML Multilingual CMS 3.1.5
WPML Media 2.1.1
WPML String Translation 2.0.5
WPML Translation Management 1.9.4
WooCommerce Multilingual 3.6.6

July 30, 2015 at 11:39 am #670010

Ahmed Ibrahim
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Thanks for contacting our support forum.

The latest version of WPML currently is 3.2.2, and the update to that version is manual only - and only for people that are not using IcanLocalize translation service.
You can read more here: https://wpml.org/2015/06/wpml-3-2-released/ and check out the video showing the update process.

After the update , I think the upload image problem should be fixed , but for deleting the ghosts images which have been already created , I will need a temporary access (wp-admin and FTP) to your site in order to provide a better help. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

+ Please make sure that you have a full backup of your website and database. (Please don't ignore this)!

Best Regards.

July 31, 2015 at 2:48 pm #671093

Muriel

Hi Ahmed,

I have removed the ghost images myself. And will test it first on another shop, which is not live.
As I do not want to compromise the live environment.

July 31, 2015 at 3:29 pm #671143

Ahmed Ibrahim
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Thanks for your reply .

Yes it's better to try the update at a test version , also I recommend you to use this series :

1. disable and remove 3.1.5
2. install 3.1.8 and activate it
3. disable and remove 3.1.8
4. install 3.2.2 and activate it

And you will need to do this manually. ( see this for more info about updating manually : https://wpml.org/faq/install-wpml/#manual-upgrade, and the link for finding all this versions : https://wpml.org/download/wpml-multilingual-cms/?section=changelog ), please make sure to deactivate all WPML add-ons.

After updating the WPML CMS plugin to "3.2.2", update all the WPML add-ons and re-activate them.

Best Regards.

The topic ‘[Closed] Media library gets corrupt when using WPML Versie: 3.1.5’ is closed to new replies.