This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by Shekhar Bhandari 6 months, 3 weeks ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
September 12, 2018 at 10:57 am #2727220

Aldo

Hello

We have not activated the media translations plugin.
But since we updated WPML to 4.0.3 in the other languages the media library is a big mess.
Many images are duplicated maybe 10x or more times.
Why? Hod do we clean that up?

Thanks
Aldo

September 14, 2018 at 5:20 am #2734017

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Thank you for contacting WPML support. I'd be happy to assist you further on this issue.

It seems unusual as media shouldn't be duplicated 10x times, it looks like there was some conflicts or PHP error which resulted in such number of duplicated.

To remove the duplicated media please follow the below steps:
* Backup your site
* Go to Media > Library
* In the WordPress admin bar, use the language selector to choose the language you want to remove.
** The media listed will be for that language.
* Select all the media, and from Bulk Actions select Delete permanently. This will delete only the media for the selected language.

Let me know if this helps.

Thanks

September 20, 2018 at 7:07 am #2751017

Aldo

You are not serious I have to do that for several hundred files??
Why in first place did you guys activate this automatically.
I not the only one with this problem: https://wpml.org/forums/topic/disabled-media-translation-in-wpml-4-0/

Are there any news if there will be a fix to just disable this "feature".

Thanks
Aldo

September 21, 2018 at 10:23 am #2754889

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I checked the ticket you mentioned, currently, on WPML 4.0.7 you can disable this feature by following the below steps:

- Install WPML 4.0.7 and WPML media translation
- Now go to WPML -> Settings -> Post Types Translation -> Media and click on the lock
- Set the media as "Not Translatable"

But while performing the above steps the image is not showing up in the media library, this issue is already being reported and being handled by our developer's team.

I have escalated this ticket to our developers and will update you as soon as I will have any update.

I hope this helps.

Thanks

September 28, 2018 at 7:52 am #2772783

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I just checked our internal system and I can confirm you that this issue fix will be added in the WPML 4.1.0 release. I don't have ETA when this will be released yet, but I will update you as soon as I will have the further update.

Thanks

March 22, 2019 at 10:54 am #3439503

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

We recently released new versions of WPML plugins with fixes and improvements so could you please update the plugin to the latest version and let me know if this helps?

NOTE:

+ Make a backup (both files and database) for your site before updating/proceeding anything (Always a good practice!). You can use a plugin for this if you like. I often use the Duplicator plugin for this purpose. See: http://wordpress.org/plugins/duplicator/