This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Yvette 2 years ago.

Assigned support staff: Yvette.

Author Posts
May 7, 2018 at 6:22 am #2003097


So I just created chinese language as cn
and everything is fine except I can't see image while I see image on other duplicated site.

Original works fine: hidden link
English works fine: hidden link
Chinese doesn't show proper image, I only see file name as 好想你 (I miss you) Cover. Joyce Chu.
See problem page here -> hidden link

I've already ticked everything about media in post (this is obvious since english duplicate works fine.)

and I tried to media translate start button
but I get this error " Translate media: please try again (error)"

I think it somewhat duplicated with image but image doesn't show properly in Chinese page.

Can you help me on this?

May 8, 2018 at 8:20 am #2025162


Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)


I understand that your featured imaged is not showing in a new language that you added to your site.

Please confirm that you have followed these steps.

1. WPML -> Tranlsation Media
Execute the options on the top half of the screen. Don´t worry, the system will skip over processing of images already processed in existing languages but will create translated/duplcated images for the new language

2. Then go to the original post and select "update".
3. Select the CN post and "update".

Does the image show up now?
If not,
1. please write back with system access details. I am opening the private area for this information. The private area is only visible between you and WPML Support.

2. Technical Information on you environment
Could you please provide information about your environment by following thsese steps:


The topic ‘[Closed] Media not showing image’ is closed to new replies.