This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Diego Pereira 12 months ago.

Assigned support staff: Diego Pereira.

Author Posts
October 18, 2018 at 12:53 pm #2827988

kay-telleH

Some of the pages, particularly the ones which have been translated by remote agency, do not show the Media section when editing the translation. Which means I'm not able to translate the Alt texts and image texts, like I am able to on the Italian language.

One strange thing is that SOME of the German pages DO show the Media section. And I can not find any setting to control this, or any logic to which pages do have Media section shown when I'm managing the page translations.

October 19, 2018 at 7:36 pm #2832894

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello @kay-telleh, welcome to the WPML support Forum!

The Media Translator has been installed / configured after sending the translations?

You can try this steps to refresh the fields on the translation editor:
- Go to the edit screen of the page (default language)
- Do a small modification on the page content and save
- Check the translation Editor

It's also possible to translate the meida attributes through WPML > Media Translator.

Please let me know if it worked for you.

All the best,
Diego