This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 12 replies, has 2 voices.

Last updated by Carlos Rojas 1 year ago.

Assigned support staff: Carlos Rojas.

Author Posts
July 31, 2018 at 2:20 am #2596301

jae-wooK

Hi~!!

We are using WPML well. Thank’s WPML

However, there is a problem with the image attachment, so I ask for support.

1) When we try media translation the images uploaded from the default language posting to media, it fails to save the image file to the local server instead of being stored in S3.

2) When we try to upload the image directly to the translation post, it will be uploaded very slowly

3) Images uploaded from the default language post will be registered normally in S3, but will appear blank in the image gallery of the translation posting and the saved location will also be a local server, not S3.

Our system environment is a structure that stores images in AWS S3.
We are using AWS Offload S3 as a plug-in.

August 1, 2018 at 1:01 am #2600070

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

1.- Please provide the steps to follow in order to reproduce the issue.

2.- I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Kind regards,
Carlos

August 1, 2018 at 6:21 pm #2603030

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Jaewoo,
Thank you very much for the information provided.

Before we continue isolating the cause of this issue I need to ask you to follow this steps:
- Update all outdated plugins to their latest version, specially WPML plugins. Outdated functionalities can cause conflicts in the code.
- Flush all cache memory.
- Double check if the issue persists.

Could you tell me the result of the steps above?

Best regards,
Carlos

August 6, 2018 at 7:16 am #2614686

jae-wooK

Dear. Carlos Rojas,

Hi~! Carlos Rojas,

I apologize for the late reply because I am on a business trip.

Share the results of applying the system.

* Apply feedback comments and eliminate suspects plugin

1. Update all plugins (WPML and other plugins)
2. Deactivate plugin “WooCommerce Multilingual”
- “WooCommerce Multilingual” was activated but it's all functions is switch off
- When this plugin is disabled, the image upload path for other language posts will be correct. (local server path -> s3 cloud front path)
3. Flush all cache memory and restart a server.

* We checked the issue by applying both real server and development server.
As a result

1. Media Translation
- Copy from the original function is not working.
- Uploaded original Image is broke
- but, use a different file upload function is well work. (Previously, this function did not work either.)

2. Images upload path
- Other launguage post images upload path is correct
- before : local server path -> now : s3 cloud front path

3. Image upload speed at other language postings
- In other language posts, the image upload speed is still slower than the default language posting image upload.

So now I am posting translations of other languages posting images manually (although slow). 🙂

Kinds Regards,

Jaewoo Kim

August 6, 2018 at 5:02 pm #2616884

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Jaewoo,
Thank you very much for your feedback.

I have created a test site in hidden link to reprode this issue from scratch. This will help us isolate the cause of the issue.

I kindly ask you to log in the site using the user: jaewoo and the same password you shared for the test user.

Please configure the site and try to reproduce the issue there. I'll will be waiting for your answer.

Thank you very much for your cooperation.
Best regards,
Carlos

August 7, 2018 at 3:34 am #2618358

jae-wooK

Dear. Carlos Rojas,

Hi~! Carlos Rojas,

1. Media Translation is not work
- If I try to translate the uploaded image into another language, it will not be converted.
- Image thumbnails are visible, but save The button “save media translation” is not activated.
- Other image upload registration function works well

2. Upload image issue in product posting
1) First, it is good to register the image independently from the language other than the default language (English).
- And the upload path is right.
S3 cloud front path - ex) hidden link
- However, if you update to the product gallery, the added image disappears.
- The same image is on the local path if you check the image in another language posting.
2) The default language posting recognizes and displays the S3 path image,
- Another language posting is that the path to the images is either a local path.
ex) hidden link
In this case, even though the local path is added to the image gallery, image registration is performed.
- The difference between the symptom of this system and my server is that the image registered with the local path is visible or not

I will remove all the theme plugins etc. from my development server and test WPML in a pure state.

Thank you again for your support.

Kinds Regards,

Jaewoo Kim

August 7, 2018 at 1:28 pm #2620370

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Jaewoo,

Please let me know when the test site is finished so I can run some tests in there.

I can see that Woocommerce Multilingual is not configured yet and all the content from Woocommerce needs to be translated (products, categories, tags, etc).

Best regards,
Carlos

August 8, 2018 at 12:45 am #2622137

jae-wooK

Hi Carlos,

Now, I have completed the Woocommerse multilanguage setup.

Then I tried uploading the image again. The result is the same.

I finished all the work on the test server.

It's your turn.

Thank you.

Kinds Regards,

Jaewoo Kim

August 8, 2018 at 8:31 pm #2626405

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Jaewoo Kim,
Thank you very much for reproducing the issue in the test site.

I have escalated this ticket to our compatibility team. Our comatibility specialists will take a deeper look at this issue and will try to isolate the cause of the issue and find a solution for it.

I will get back to you as soon as I get an answer from our compatibility team.

Thank you very much for your patience and understanding!
Best regards,
Carlos

August 27, 2018 at 7:47 pm #2679841

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

I would like to ask you to follow this steps:
- Go to WPML -> Settings -> Custom XML Configuration -> Add this code:

<wpml-config>
<custom-fields>
<custom-field action="copy">amazonS3_info</custom-field>
</custom-fields>
</wpml-config>

- Save the XML.
- Add a new image and check if the issue persists.

Could you tell me the result of the steps above?

August 28, 2018 at 2:25 am #2680394

jae-wooK

Hi Carlos,

How have you been

I put the setting value as advised and tested it in a clean environment after the service start.

But unfortunately, the issue result is still the same.
In the default language posting, the image is uploaded to the S3 path well, but if you translate it to another language post, the image will be attached but the path will be the local server path.

So now we are avoiding the problem by ignoring the local path image of the translation posting and uploading the image of the basic language posting equally again.

Default language (Eng) image upload path
- s3 cloudfront path - hidden link

Other translation language (Zht-TW) image upload path
- local server paht - hidden link

Thank you.

August 28, 2018 at 12:42 pm #2682251

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you very much for your message.

I just updated our compatibility specialists about the result and they are looking for another solution. I will get back to you as soon as I have an answer from them.

Thank you very much for your patience and understanding!
Best regards,
Carlos

September 28, 2018 at 6:02 pm #2774590

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

I fix for this issue will be included in the next release of our plugin.

Best regards,
Carlos