This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 15 replies, has 3 voices.

Last updated by Jamal 2 months, 3 weeks ago.

Assigned support staff: Jamal.

Author Posts
June 27, 2019 at 10:18 am #4098967

jaapB-3

Hi Jamal,

I did several tests.

- I uploaded an image with underscore in the name. And repeated the translation process. That did not do the trick.

- I uploaded an image with middelscore in the name. And repeated the translation process. no difference.

- I uploaded png instead of jpg, no difference.

- I uploaded an image by my second admin account, no difference.

- I tested a post with your uploaded image, that succeeded. I got the translated image in the translated post.

- I looked in the media library and selected russian / spanish, I see all the translated images, including mine.

It seems that it works with your uploaded images, but not with mine and also not with Sannes images. So what could be the difference?

- It could be that something happens in your upload that is different
- It could be that something happens in your translation that is different

1. I uploaded a new image, without translating it or using it. Could you paste it in a post, and translate it by uploading the translations, I send them here.

2. I notice another thing. My adminaccounts are both translationmanagers, but one of them sees only spanish translations when I look under 'translations', and in the other one, I see no translations. How do I manage the languages of the managers? Could that do something? I think not, because when I pick an image that you uploaded, it took the translated image. And than I would have to succeed in at least one language.

Looking forward to one more bright idea towards a solution.
What if I go over to the classical translation? Is that a plan B? Will I be able to translate the pictures easily of the translated posts?

Best regards,
Marjon

June 27, 2019 at 10:21 am #4099045

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hi Marjon,

Can you please run another test in the migrated server.
hidden link

I fixed the issue with file permissions, and you will be able to upload files in there.

For more information about the migrated server see our previous ticket
https://wpml.org/forums/topic/media-translation-not-working-2/page/2/#post-3673317

Best regards,
Jamal

June 27, 2019 at 11:19 am #4099555

jaapB-3

Hi Jamal,

Thanks for reopening the issue. I did some tests with an existing testpost 2 and a new testpost 3.

For testpost 2
- I uploaded a new english image in the content.
- By translationmanagement I set it to translation.
- I changed to the editor
- I translated the images
- I translated the post.
No result

For testpost 3
- I uploaded an existing english image in the content. (but it had no translation yet)
- By translationmanagement I set it to translation.
- I translated the images
- I changed to the editor
- I translated the post.
No result
Note: I did only one translation: russian, and I translated the images in this test while I was in the Adminrole.

What could I do for more tests? Should I test with your account?

Thanks and best regards,
Marjon

July 1, 2019 at 1:26 pm #4119379

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

I run some tests too on the migrated server, and it works with my images and does not work with your images.

JTest1 EN:
- Created a post with my admin user (jamal.b)
- Uploaded image to it
- Send to translation from Translation Management
- Login as Editor (jamal.b.editor)
- Uploaded Russian image and translated post to Russian.
It works

JEditor post1 EN (by mistake I created a page)
- Created a page and uploaded an image with my Editor user (jamal.b.editor).
- Sent page to translation with my Admin User (jamal.b)
- Updated password for Editor user (Test Marjon) and logged in with it
- Translated image and post
It works.

JEditor Test2 EN:
- Created a post and used my admin image, my editor image, and your admin image.
- Sent page to translation with my Admin User (jamal.b)
- Logged in with user (Test Marjon)
- Translated post
It worked for my images and not for your image.

Then I activated User Roles Editor and compared your admin user with mine. The only difference I found is "manage_translations" capability that your user has and mine don't.

There is also the Toolset Access plugin that handles Posts, Pages and Media post types permissions.

I would like you to run a few more tests on the migrated site, as I suspect that Toolset Access is probably behind this issue.
Can you please try again with a new Admin User, but this time, please deactivate "Toolset Access" and "User Roles Editor" before creating this user. Then run your tests without activating Toolset Access. If the issue is not present, please run another test with your admin user while Toolset Access is deactivated.

If the issue is is always present in all these tests, please try again with a new admin user, while deactivating all plugins except WPML ones.

Thank you,
Jamal

July 4, 2019 at 8:48 am #4141395

jaapB-3

Hi Jamal,

I did a lot of tests in the meantime. And I got a clue:

Deactivating Toolset Access and User Roles Editor did not help. Deactivating all plugins did help though.
So I activated them again by groups and I did come out to the Classical Editor. When I deactivated it, the bug did not occur, activating it, it did. Also on our live website: With a deactivated Classical Editor I saw the translated images in the translated posts. Activating the Classical Editor gave the same bug again. (I did not test it with already uploaded images.)

I tried in your workingspace as well other plugins that deactivate Gutenberg. But they gave the same bug as the Classical Editor.

I discovered also that I could see during the translation process when I would see the translated pictures and when not: When you click on 'finish' or 'complete' You come in an overview. When I see a picture there, I know I will not see the right picture. When I see no picture there, I know the picture will be translated in the translated post.

Why your test were succesfull, is not clear to me.

So, coming so far was a hell of a job, but the problem seems now clear. Any solution to this that you know of?

Best regards,
Marjon

July 5, 2019 at 9:09 am #4149451

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hi Marjon,

Thank you for your feedback. I tried to check if the erroneous images in my posts get resolved if Classic Editor is deactivated to no avail. Check my post:
- hidden link

It holds images that I have translated and one that you have translated before. Even if Classic Editor is deactivated, the Russian post still shows your English image.

If you can show me a post that has the issue when the Classic Editor is activated and does not have it when it is deactivated. I can escalate it to our 2nd Tier for further analysis. To check why is this happening.

Thank you,
Jamal

July 5, 2019 at 11:53 am #4151053

jaapB-3

Hi Jamal,

Because I used the same picture all these tests (uploaded it again and again) It is hard to see which one is uploaded when.

I made 2 new pictures with translations. And I tested them again in two new tests. And what happens, in your surrounding I get now the right translations. In the actual website it is still not good. What is different than yesterday. Nothing I think. I did after my tests also tests with other Gutenburg blocking plugins. That I did not on the actual website. And in your surrounding, the licence key of the plugin that arranges the post order, is not given. So that could be a clue, but that was yesterday also the case.

But anyway, you can see both tests in your surrounding and in the live website. I hope you can test it to see what it does with the use of those pictures in other posts. I uploaded it consequently with a admin account. And I translated with the editor account. I used the new administrater in the cloudappsalways. But that was yesterday the same.

Best regards,
Marjon
Marjon

July 5, 2019 at 2:44 pm #4152227

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello Marjon,

I checked the live site and I can see that it worked for the post #8733 and its Russian translation #8739. But not for #8716 and its Russian translation #8724.

The only differences I could spot is version differences for several plugins and the Disable Gutenberg plugin that you mentioned.

In your opinion what was the difference in your last 2 tests (#8733 which is ok and #8716 which is not)?

If we can't understand what's the clue here. We may migrate your website again to another server and look it up again there. It is possible that the issue is actually triggered by a combination of plugins(Classic Editor included).

Thank you,
Jamal

July 8, 2019 at 11:48 am #4162063

jaapB-3

Hi Jamal,

In answer of your question: In your opinion what was the difference in your last 2 tests (#8733 which is ok and #8716 which is not)?

I made these translations on the live website while
- the Classical Editor was disabled (#8733 which is ok)
- the Classical Editor was enabled (#8716 which is not ok)

When I enable the Classical Editor afterwards makes no difference in the translation that is done. It stays ok.

I just now tested whether I could re-use the properly translated picture in a post uploaded from the medialibrary while the Classical Editor was activated. And it did not work.

I tested again with a second post and re-used the properly translated pictur in a post uploaded from the medialibrary while the Classical Editor was de-activated. And it did work.

I translated the last test in 2 ways. I send them both in translation management to the translator while the Classical Editor was de-activated.

I translated the post in Spanish while the Classical Editor was de-activated. It works well.
I translated the post in Russian while the Classical Editor was activated. It works well too.

So
- the images must be translated while CE is not activated
- the posts should be made and sent to the translator, when these pictures are re-used, while the CE is not activated. After that it is not important anymore.

Now the last question is, how will the allready uploaded images which are not translated yet, work in these circumstances.

And I suspect here a bug, with CE, maybe in combination with other plugins.

Best regards,
Marjon

July 9, 2019 at 9:21 am #4168939

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello Marjon,

Thank you for your feedback. I am approaching our 2nd Tier again for assistance on what to do next.

Best regards,
Jamal

July 11, 2019 at 10:37 am #4188733

jaapB-3

Hi Jamal,

Looking forward for your replay.

Best regards
Marjon

July 16, 2019 at 11:30 am #4219639

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello Marjon,

Our apologies for the late reply. The issue is still under analysis by our 2nd Tier. We'll get back to you as soon as possible.

Best regards,
Jamal

July 16, 2019 at 1:38 pm #4220557

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello Marjon,

We were only able to reproduce the issue with the images you have uploaded. We still cannot understand how this was possible. As of now, the issue is escalated to our developers and I'll get back to you as soon as possible.

Best regards,
Jamal

July 30, 2019 at 9:55 am #4306587

jaapB-3

Hi Jamal,
Thanks, I will disabel the ATE today at the live website and replace the images in the translated posts. because it is taking so long now. But it is not ideal.
Tomorrow until the 19th of august I will be unavailable because of a holiday. Hopefully you can keep this issue open until than and let me know?
Thanks,
Best regards,
Marjon

July 30, 2019 at 11:52 am #4307471

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+02:00)

Hello Marjon,

As Jamal is also not available today, I'll change the status of your ticket and he will back to you as soon as we have any news from our 2nd tier support.

Regards,
Andrés

The topic ‘[Closed] Media translation not working for some users’ is closed to new replies.