This thread is resolved. Here is a description of the problem and solution.

Problem:
Content added via Divi blurb is displayed correctly in editor, but not on the frontend of the website.

Solution:
Altered the XML configuration for Divi, add next code to WPML>Settings>Custom XML Configuration:

[php]

et_pb_blurb

title
title_phone
title_tablet
alt
image
background_image
link_option_url
url
content_tablet
content_phone

[php]

Update original language content and finish translation 100%.

Relevant Documentation:
https://github.com/OnTheGoSystems/wpml-config/blob/master/Divi/wpml-config.xml

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 2 voices.

Last updated by saschaW-9 1 week, 4 days ago.

Assigned support staff: Dražen Duvnjak.

Author Posts
May 19, 2020 at 2:58 pm #6169081

saschaW-9

Auf der Website: hidden link funktionieren mehrere Übersetzungen nicht. Wir haben eine riesige Menge an Übersetzungen bei Avanti Language bestellt (Volumen von mehreren Tausend Euro).
Nun habe ich diese importiert und habe einige Probleme:

1. In den Übersetzungen sind im HTML Code überall Leerzeichen die dort nicht rein gehören.
(Siehe Screenshot "avanti_antwort")

2. Im Translator werden Inhalte richtig übersetzt angezeigt, auf der Website dann nicht.

Beispiel:
This content came from the Block editor and you need to translate it carefully so that formatting in not broken.

Beispiel:
hidden link
Hier werden die Module in der Mitte nicht übersetzt:
hidden link

3. Links werden nicht automatische korrigiert auf den Seiten.
Auf allen Seiten werden im Inhalt die Links nicht korrigiert. Nur im Menü hat es funktioniert.
Auch die YOAST SEO Breadcrumbs werden nicht umgebaut.

Könnt ihr mir helfen?
Suche schon seit 10 Stunden verzweifelt nach dem Fehler.

May 19, 2020 at 8:38 pm #6172041

saschaW-9

1. In the translations there are spaces in the HTML code that do not belong there.
(See screenshot "avanti_antwort")

2. Content is displayed correctly translated in the translator, but not on the website.

Example:
hidden link
The modules in the middle are not translated here:
hidden link

3. Links are not automatically corrected on the pages.
The links on all pages are not corrected. It only worked in the menu.
The YOAST SEO Breadcrumbs will not be converted either.

Can you help me?
Desperately looking for the bug for 10 hours.

May 21, 2020 at 6:38 am #6183717

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hello,

1) WPML breaks the content into sentences. This allows the editor to keep track of all the translated text. Does this issue cause any issue on the frontend or show wrongly?

2) When I try to visit hidden link, I am redirected to the DE webpage, I can not see any EN page.

Can you please enable and publish it, so I can see the issue.

3) Links are not automatically corrected on the pages.

Do you mean on this translated page? Can you please share more info and example of the issue, so I can see.

Thanks and regards,
Drazen

May 21, 2020 at 10:15 am #6185403
saschaW-9

1) I thought that was a mistake. Then that's not a problem!

2) I published it.

3) Do you mean on this translated page? (yes, and on many other sites.) The example is about the YOAST SEO Breadcrumbs LINKS (they are not changed, even if I adjust the links via the Settings menu).
It's also about the 3 boxes in the middle.

New threads created by Dražen Duvnjak and linked to this one are listed below:

https://wpml.org/forums/topic/split-links-in-2nd-language-not-transalting-correctly/

May 21, 2020 at 12:35 pm #6186457

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hello,

thanks.

3) Can you confirm the issue is with the 3 boxes where the first one starting with SKIDHEBER?

For the issue with the links I have opened a new ticket. We limit 1 issue per ticket that way, the topic is clear and easy to follow.

Ticket: https://wpml.org/forums/topic/split-links-in-2nd-language-not-transalting-correctly/

In order to investigate this issue and to understand it better, I would need to access your website.

Please make a full backup of your site (files and database) and confirm it in your next reply. I might need to enable/disable plugins, switch themes and access your website database.

I would need to access both your site's wp-admin and FTP account. Be sure to provide both.

I have enabled the private username and password fields in your next reply.

I suggest you create a temporary user, set it as an administrator and then add those credentials in the private fields mentioned.

You can safely add your information into these fields.

Thanks and regards,
Drazen

May 22, 2020 at 1:06 pm #6195741

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hello I have checked your issue with the boxes.

It seems you have altered XML configuration for Divi. I have found inside WPMl>Settings>Custom XML Configuration there is a missing rule for the Divi blurb module. That way it it was missing also from translation.

I have added:

        <shortcode>
            <tag>et_pb_blurb</tag>
            <attributes>
                <attribute>title</attribute>
                <attribute>title_phone</attribute>
                <attribute>title_tablet</attribute>
                <attribute>alt</attribute>
                <attribute type="media-url">image</attribute>
                <attribute type="media-url">background_image</attribute>
                <attribute type="link">link_option_url</attribute>
                <attribute type="link">url</attribute>
                <attribute encoding="allow_html_tags">content_tablet</attribute>
                <attribute encoding="allow_html_tags">content_phone</attribute>
            </attributes>
        </shortcode>

This is the original default XML configuration that comes with the Divi theme.

- hidden link

Then I have changed the title on the original page and updated translation.

- hidden link

As for button links, I have run Scan and adjust the link. Then after the finish, if you update the original language page and update the translation, button and link are correct.

- hidden link

I am still working YOAST breadcrumbs issue in other tickets and will update you there.

Please check the pages and let me know if everything fine.

Regards,
Drazen

May 22, 2020 at 1:27 pm #6195901

saschaW-9

Hello Drazen,

thank you very much!

Now there is there still a little problem:
On the product pages where the button was, the headings of the Blurb modules are not translated. (See the screenshot)

Or do I have to rename the pages to make it work? What did it have to do with the renaming?

greetings

Sascha

May 23, 2020 at 12:17 pm #6200933

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hello,

What did it have to do with the renaming?
You just need to add some new character to the original language page, for me it the easiest to add something to the title. That way we say to WPML plugins that original content changed and translation needs to be updated. After we update and finish the translation, it should show all correctly.

I was able to solve the issue. To avoid any mixup and since this is a global element I edited and translated only this global element via Divi>Divi Library.

Steps I take:
- Disabled all plugin except for WPML plugins
- Go to Divi library and click to edit original languages global layout
- Changed INDIVIDUELL NACH IHREN WÜNSCHEN > INDIVIDUELL NACH IHREN WÜNSCHEN 1
- Saved
- Clicked on the icon to update the translation
- Updated and finished translation in the Advanced translation editor
- Checked frontpage all seemed correct

- Go to original languages global layout
- Changed title back and updated translation

You will need to update Dutch translation.

Please check and let me know if there is anything else I can do for you.

Regards,
Drazen

May 23, 2020 at 7:02 pm #6202009

saschaW-9

Hey Drazen,

thank you. i think the problem is solved. i resave all papges and translations on monday and give you feedback. Thanks a lot!

May 25, 2020 at 12:49 pm #6210315

saschaW-9

My issue is resolved now. Thank you!