Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Sun Mon Tue Wed Thu Fri Sat
- 9:00 – 12:00 9:00 – 12:00 9:00 – 12:00 9:00 – 12:00 9:00 – 12:00 -
- 13:00 – 18:00 13:00 – 18:00 13:00 – 18:00 13:00 – 18:00 13:00 – 18:00 -

Supporter timezone: Asia/Singapore (GMT+08:00)

Tagged: 

This topic contains 47 replies, has 4 voices.

Last updated by Kor 8 months, 4 weeks ago.

Assisted by: Kor.

Author Posts
July 20, 2023 at 11:54 am #14071939

khorenN

Hello,

My website keeps hitting memory limits and the cause seems to be the WPML plugin. While using it understandably slows down the overall back end (wordpress dashboard) and front end performance, there shouldn't be such issues.

Here is an example of the errors :

[20-Jul-2023 11:26:16 UTC] PHP Fatal error: Allowed memory size of 1073741824 bytes exhausted (tried to allocate 262144 bytes) in /home/cc05mth/public_html/wp-content/plugins/sitepress-multilingual-cms/vendor/wpml/fp/core/functions.php on line 139
[20-Jul-2023 11:27:04 UTC] PHP Fatal error: Allowed memory size of 4294967296 bytes exhausted (tried to allocate 20480 bytes) in /home/cc05mth/public_html/wp-includes/functions.php on line 4811
[20-Jul-2023 11:27:46 UTC] PHP Fatal error: Allowed memory size of 4294967296 bytes exhausted (tried to allocate 20480 bytes) in /home/cc05mth/public_html/wp-includes/functions.php on line 4811

I currently have Memory limit 4096M & Max memory limit 1024M, but it still hits the limit and i get "Http error 500" errors. I have to regularly clear my caches for the website pages to load properly again.

I think there is some action/computing that WPML is trying but not succeeding, which keeps eating the memory until it simply runs out.

PS : i mostly use well known popular plugins, everything is up-to-date.

Best regards,
Khoren.

July 20, 2023 at 3:47 pm #14074195

khorenN

After some more digging into the forum and trying things, first i can confirm that the issue comes from WPML as deactivating the plugin makes the pages load again.

During my tests, i noticed the http error 500 only appears for my default language : domain.com

The other language directories like domain.com/fr, .com/es, etc, load without issues.

I found various tickets mentioning different sources to the issue and solutions. There was a lot of mentions about the htaccess rules being rewriten. I tried a php code solution that was given but it didn't seem to help.

I found another post mentioning changing the language URL formats, after testing swtiching to "language name added as a parameter" instead of different directories, the default language URLs started loading again.

So there's certainly an issue and it seems to be related to the main directory, maybe it's redirecting from .com to .com/en instead ? The default language is not in a directory. So it could be a conflict in the settings/rules that are being rewritten ? In the htaccess or somewhere else ?

In any case, after it works for a short while, after an hour or a few hours, something changes and it blocks my default language URLs with the same error.

I would really appreciate help with this as it will hurt my pages being indexed and my SEO.

Best regards,
Khoren

July 21, 2023 at 6:59 am #14076331

Kor
Supporter

Languages: English (English )

Timezone: Asia/Singapore (GMT+08:00)

Hi there,

Thanks for contacting WPML support.

I will need to closely examine your website. Therefore, I will require temporary access (WP-Admin and FTP) to a test site where the problem has been replicated, if possible. This will enable me to provide better assistance and determine if any configurations need to be modified.

Please note that it is important to have a backup for security purposes and to prevent any potential data loss. You can use the UpdraftPlus plugin (https://wordpress.org/plugins/updraftplus/) to fulfill your backup requirements.

Your forthcoming response will remain confidential, accessible only to you and me.

✙ To resolve the issue, I may need your consent to deactivate and reactivate plugins and the theme, as well as make configuration changes on the site if necessary. This emphasizes the significance of having a backup.

July 24, 2023 at 6:36 am #14085713

Kor
Supporter

Languages: English (English )

Timezone: Asia/Singapore (GMT+08:00)

Thanks for your reply.

I've checked and you might be facing the same issue as this one https://wpml.org/forums/topic/conflict-with-wpml-and-object-cache-pro/ . Could you try the steps explained in that ticket and see if it helps? Ref: hidden link

Also, you might want to check the WP Rockets plugin to see if it's conflicting with Object Cache Pro and WPML.

July 24, 2023 at 2:40 pm #14090597

khorenN

Thank you for your answer.

I will look into that with my hosting support.

Were you able on your end to investigate the potential conflicts between WPML and WP Rocket ?

It is weird that on my staging website i do not have any issues. Yet on my live website, whenever i activate object caching, fairly soon i start getting the http error 500 on my defaut language URLs.

July 24, 2023 at 5:56 pm #14092037

Kor
Supporter

Languages: English (English )

Timezone: Asia/Singapore (GMT+08:00)

Thanks for your reply.

There are actually no known issues with WP Rockets when used with WPML as shown here https://wpml.org/plugin/wp-rocket/ .

It could be isolated to your Website for some reason. Probably some settings from Object Cache Pro and WPML/WP Rockets that are conflicting.

If nothing is useful and the issue still persists, I could escalate this to our 2nd Tier Support for further assistance. Let me know.

July 30, 2023 at 1:49 pm #14122907

khorenN

Hi,

Thank you for your answer.

I have been busy but i'll look into the potential solutions and keep updated on it. So this ticket doesn't get closed.

Best regards,
Khoren

July 30, 2023 at 9:07 pm #14123347

Kor
Supporter

Languages: English (English )

Timezone: Asia/Singapore (GMT+08:00)

Thanks for your reply.

Yes, please let me know how it goes.

July 31, 2023 at 4:07 am #14123567

khorenN

Hello,

I was able to spend a couple hours with my hosting support team to look into this. We tried the previously mentioned solution for ignoring groups, but it didn't help.

The team tried different things to see what the issue is and here is what the conclusion seems to be from their end :

"It looks like these plugins are causing issues:
[31-Jul-2023 03:23:12 UTC] PHP Fatal error: Allowed memory size of 4294967296 bytes exhausted (tried to allocate 20480 bytes) in /home/cc05mth/public_html/wp-includes/class-wp-term-query.php on line 731
[31-Jul-2023 03:23:17 UTC] PHP Fatal error: Allowed memory size of 4294967296 bytes exhausted (tried to allocate 262144 bytes) in /home/cc05mth/public_html/wp-content/plugins/sitepress-multilingual-cms/vendor/wpml/fp/core/functions.php on line 139
[31-Jul-2023 03:23:28 UTC] PHP Fatal error: Allowed memory size of 4294967296 bytes exhausted (tried to allocate 20480 bytes) in /home/cc05mth/public_html/wp-includes/class-wp-term-query.php on line 731
[31-Jul-2023 03:24:44 UTC] PHP Fatal error: Allowed memory size of 4294967296 bytes exhausted (tried to allocate 20480 bytes) in /home/cc05mth/public_html/wp-includes/class-wp-term-query.php on line 731
[31-Jul-2023 03:24:46 UTC] PHP Fatal error: Allowed memory size of 4294967296 bytes exhausted (tried to allocate 20480 bytes) in /home/cc05mth/public_html/wp-content/plugins/sitepress-multilingual-cms/classes/utilities/class-debug-backtrace.php on line 137
[31-Jul-2023 03:24:54 UTC] PHP Fatal error: Allowed memory size of 4294967296 bytes exhausted (tried to allocate 20480 bytes) in /home/cc05mth/public_html/wp-includes/functions.php on line 4811
[31-Jul-2023 03:25:15 UTC] PHP Fatal error: Allowed memory size of 4294967296 bytes exhausted (tried to allocate 262144 bytes) in /home/cc05mth/public_html/wp-content/plugins/sitepress-multilingual-cms/vendor/wpml/fp/core/functions.php on line 139
[31-Jul-2023 03:25:32 UTC] PHP Fatal error: Allowed memory size of 4294967296 bytes exhausted (tried to allocate 20480 bytes) in /home/cc05mth/public_html/wp-includes/functions.php on line 4811
[31-Jul-2023 03:26:41 UTC] PHP Fatal error: Allowed memory size of 4294967296 bytes exhausted (tried to allocate 20480 bytes) in /home/cc05mth/public_html/wp-includes/class-wp-term-query.php on line 731
[31-Jul-2023 03:27:29 UTC] PHP Fatal error: Allowed memory size of 4294967296 bytes exhausted (tried to allocate 20480 bytes) in /home/cc05mth/public_html/wp-content/plugins/sitepress-multilingual-cms/classes/utilities/class-debug-backtrace.php on line 137

By default, we have 1 GB of PHP memory – and it should be enough for any plugins/themes to finish the operation. Even though, wp memory limit has been added to 4 GB on wp-config.php, but WordPress would be following the PHP memory set on the server side.

So, in this case, looks like the memory leak caused by the plugins has consumed OCP memory cache."

They add that "The plugin shows up to eat the allotted PHP memory limit. Usually it's set to 256M on other hosting provider, but we have pretty high limit, which is 1 GB – but still don't seem enough to run those plugins."

From what we understand, the root of the issue is that WPML has abnormal memory consumption, whether it's from some settings in the plugin or a conflict with something that causes too many requests then overloads the memory or just one request that isn't being able to be processes or throwing a loop or i don't know...

They also think the reason it doesn't cause any issues on staging copy is probably because there isn't much of a running process inside the staging (and no actual trafic).

I can give you access to the main website admin/ftp as well potentially. But i would want your team to be much more careful doing tests on it to avoid any changes that might affect negatively my overall configuration and because there's work being done on it regularly with added content, etc, so i wouldn't want to get back on a backup.

Looking forward to hearing back from you.

Best regards,
Khoren

July 31, 2023 at 8:13 am #14124715

Kor
Supporter

Languages: English (English )

Timezone: Asia/Singapore (GMT+08:00)

Thank you for your prompt response.

To clarify, the issue appears to be specific to your production site and arises only when the WPML plugin is activated. Interestingly, everything functions correctly when the WPML plugin is deactivated.

To provide you with the best possible support, I will escalate this matter to our 2nd Tier Support for further assistance. Since we were unable to replicate the problem on our staging site, we kindly request your permission to obtain a site snapshot. Alternatively, if you prefer, you may create a snapshot on your own and share it with us.

For creating the snapshot, we recommend using the free "Duplicator" plugin. If you are already familiar with Duplicator's functionality (https://wordpress.org/plugins/duplicator/), you can skip the following steps and simply provide us with the archive file directly.

To proceed, please follow these instructions:

1. Watch the Duplicator instructions video: hidden link
2. Refer to the instructions provided by WPML on how to share a copy of your site with supporters: https://wpml.org/faq/provide-supporters-copy-site/

If the archive file exceeds 400MB in size, you can utilize Duplicator's file filters to exclude the cache, wp-uploads directory, media, and archive files.

Once you have created the archive file, please share the link with us. You can use services such as Google Drive, Dropbox, or similar platforms, as the snapshot file might be large.

Rest assured that any information you share in your next reply will remain private, visible only to you and me. You can paste the link to the file there. After resolving the issue, we will promptly delete the local site to ensure your data's security.

Furthermore, kindly provide both WP and FTP access details for your production site, and I will include this information in the report for our 2nd Tier Support.

August 8, 2023 at 1:38 am #14166479

khorenN

Hello,

I want to quickly mention that i updated WPML to the newest version after i received notification of it being available.

Best regards,
Khoren

August 8, 2023 at 1:52 am #14166485

Kor
Supporter

Languages: English (English )

Timezone: Asia/Singapore (GMT+08:00)

Thank you for responding.

I have reviewed your production site. Could you please provide specific steps to replicate the issue? When I checked, the site appeared to be functioning smoothly while navigating through the products and performing actions like adding items to the cart or making selections. Additionally, the backend also appeared stable during my assessment.

August 8, 2023 at 2:22 am #14166493

khorenN

As mentioned and confirmed previously, the http error 500 appears when we activate the Object Cache (you can see currently deactivated in the plugins page).

And even while everything is functioning smoothly without object cache, it is thanks to the server with a quite high compute power that my current host provides. But it doesn't cancel out the Object Cache conflict with WPML and, as importantly, the memory usage issue despite the back end and front end functioning well.

Only a month ago I was on another hosting that was still quite good quality (WPX) but had lower compute power than the current one, and it had gotten to a point of constant server overloads and both the backend and frontend performance was getting super slow, especially the backend was absolutely terrible. It got to that point progressively as I added content to the site over the months, at first it was ok.

So, there are two things to look into, please :

- Memory usage issue coming WPML (please see the errors log i provided in previous messages) as while we have a powerful server, there's still an issue with that. On the server, the current memory limit is 4096M & Max memory limit is 1024M. But, there are php errors due to memory.
- Object Caching is quite useful for the type of website i have so i want to be able to use that option, but when activating it, it throws http error 500 on my default language URLs. But weirdly enough not on translated subdirectories. It could be either code related bug or linked to the other issue (memory usage).

August 8, 2023 at 7:07 pm #14172043

khorenN

Hello,

Thank you for your answer.

After i noticed your message, i went on the website and as expected seeing that a few hours have gone by, it had the error. You can see in the attached screenshot, as it is visible to the public, i hid personal details but left the first two letters of the website name next to the error so you know it's the same one. Can also see the date and time.

I had to deactivate the plugin, so visitors wouldn't have an issue for long time, since i don't know when you'll see this message.

There is no particular steps to replicate, only a matter of waiting, actually. Sometimes it may give the error within minutes, sometimes take half an hour or an hour, but mostly it's fairly quickly throwing the error. You must have immediately checked after activating.

I can of course send you a video showing it too if you want. I can create one later on during a non-high traffic period of the day.

Let me know what you would need and how you prefer to proceed.

Screenshot 2023-08-08 203015.png
August 9, 2023 at 5:35 am #14172849

Kor
Supporter

Languages: English (English )

Timezone: Asia/Singapore (GMT+08:00)

I appreciate your response.

As demonstrated in the screen recording I previously provided, I attempted to navigate the website after enabling the "Object Cache" plugin, but I was unable to reproduce the issue.

Could you kindly create a screen recording where you activate both WPML and the Object Cache, and then document the steps leading to the crash?

Feel free to share the video link privately through the provided method (WP admin access login URL) that I've set up for you to ensure privacy.

The topic ‘[Closed] Memory limit issues due to WPML’ is closed to new replies.