Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 11 replies, has 3 voices.

Last updated by Bruno Kos 7 months ago.

Assigned support staff: Bruno Kos.

Author Posts
March 5, 2021 at 6:43 pm #8238747

marketingD-8

We recently switched from the XTM plugin to the Memsource plugin. The XTM plugin did not work for us, so we searched for an alternative. Our initial tests on a dev site we good, but now that we're working with existing content, we're experiencing issues. The existing content/pages are coming back as new pages, not the expected behavior using WPML. When the content is pushed back from Memsource, it creates two new pages for the translated content (Spanish & Chinese), besides the English version. See the attached image.

2021-03-05_13-30-31.png
March 7, 2021 at 2:10 pm #8245453

Bruno Kos
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Zagreb (GMT+01:00)

Hi,

Thank you for contacting WPML support!

When you say:

The existing content/pages are coming back as new pages, not the expected behavior using WPML.

You mean you do this?
- Choose any existing page
- Send it through Translation management to Memsource (even if it was translated already)
- you translate it there and complete to 100%, meaning it should return to your site through our translation proxy
- it doesn't update the translation but creates a new page?

Are you able to create a short video about the whole process and where the bug is then to be seen?

I will then consult our 2nd tier about this, as I am unsure what could be happening here.

Regards,
Bruno Kos

March 8, 2021 at 1:54 pm #8252977

marketingD-8

That is correct. Existing content translated by Memsource comes back as new pages for the languages (Chinese & Spanish). If we clone them before having Memsource translate them, they come back fine. I'll work on getting you a video.

March 8, 2021 at 5:10 pm #8255447

marketingD-8

Here's a video showing what we are experiencing. hidden link

March 9, 2021 at 8:46 am #8259791

Bruno Kos
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Zagreb (GMT+01:00)

Hi,

I am not sure about this, given the complex integration and very little tickets we have with it, such as https://wpml.org/forums/topic/when-i-click-on-translate-link-target-all-translation-saved-in-pages-are-lost/.

Can you tell me it is possible to emulate this problem in sandbox setup if I prepare one for you?

What does it take to implement Memsource to your site, this plugin or you need to register for the service as well (I am not familiar with how it works)?
hidden link

However, did you try reaching our their support and ask them about:
- joining https://wpml.org/documentation/theme-compatibility/go-global-program/
- https://wpml.org/announcements/2013/11/wpml-project-invites-translation-services-join/

We only had one case with and was quite complicated also:
https://wpml.org/forums/topic/when-i-click-on-translate-link-target-all-translation-saved-in-pages-are-lost/

So the best way to tackle Memrise problems is to have our compatibility team direct contact with Memrise, in case they are interested though.

Regards,
Bruno Kos

March 10, 2021 at 6:21 pm #8277855

marketingD-8

I'm wondering if performing a reset on WPML and starting over would be of any benefit. I understand we'd lose all existing translations, but up till now, we've been only testing specific pages and reuseable blocks. What would you recommend?

March 11, 2021 at 7:00 am #8280841

Bruno Kos
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Zagreb (GMT+01:00)

Hi,

I would recommend either of these:
- see with their support if they can shed some light on this
- I can setup a sandbox site for you to see if this is reproducible there
- if you provide us with all the logins and correct steps to reproduce (I do see this is complicated procedure though), maybe our compatibility team can trace the error

Reset should be the last resort and only in specific cases and when nothing has been translated yet. There is also no guarantee that this is not a bug in Memsource so resetting would not fix anything.

Regards,
Bruno Kos

March 11, 2021 at 6:28 pm #8288565

marketingD-8

We have this setup on a staging site (Sandbox) right now. I can grant you access.

March 14, 2021 at 8:26 am #8304211

Bruno Kos
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Zagreb (GMT+01:00)

Hi,

I marked your next reply as private so that you can safely add credentials.

And if possible, provide provide steps to reproduce if possible, as detailed (but brief).

I will then sent it all to our 2nd tier support for further checks as there is nothing I can suggest here myself.

Regards,
Bruno Kos

March 16, 2021 at 10:41 am #8319177

Bruno Kos
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Zagreb (GMT+01:00)

Hi,

Truth be told I am not sure how to approach this, so I asked our translation services specialists for suggestions.

I will keep you posted on how it goes.

Regards,
Bruno Kos

March 17, 2021 at 10:59 am #8330689

Ahmed Mamdouh
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi,

This is Ahmed Mamdouh from the translation proxy team.

I've checked the issue and as far as I understand (correct me if I'm wrong) that the issue mainly is you are facing an undesired behavior in some pages (not all of the pages) while trying to translate them using memsource, and when you contacted them, they advised to check some options in WPML (the used editor for the new content option) are set, and you did but you still have the same issue.

If the issue summary I mentioned in the above paragraph is right, I think it might be a compatibility issue with memsource, to make sure of that please deactivate all WPML Plugins and try to replicate the same issue, if it replicated, that's mean that the issue mainly from memsource and WPML is not part of this issue.

if it's not replicated, that means that there is a compatibility issue between memsource and WPML, in this case, you need to report this issue to memsource and let us know if they required anything from our side.

There is another possibility that memsource is having a bug or issue with original/older legacy pages in your website and in this case unfortunately we couldn't help as we are not experts in how memsource working.

Best regards,
Ahmed Mamdouh

April 28, 2021 at 11:15 am #8643735

Bruno Kos
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Zagreb (GMT+01:00)

Hi,

Can you tell us if you have any news for us?

Regards,
Bruno Kos