This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 33 replies, has 2 voices.

Last updated by Andreas W. 8 months, 2 weeks ago.

Assigned support staff: Andreas W..

Author Posts
December 19, 2018 at 12:39 pm #3016395

susanV-3

The only issue now is that the menu on top (on the english page) is in dutch. And i can't get it in the right language. And the pictures on the english pages are not the right ones.

For example: on the page hidden link are the pictures of the dutch site. The links in the back are okay.. 🙂

Logins here: https://wpml.org/forums/topic/when-i-translate-a-page-it-doesnt-show-on-the-other-language-page/#post-3012798

December 19, 2018 at 1:28 pm #3016513

susanV-3

It's not just the picture translation, when i make any adjustment on a english page, it just doesn't show on the front and when i refresh my wordpress, everything i changed is just gone.. 🙁

December 19, 2018 at 10:25 pm #3018276

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi!

Thank you for contacting WPML Support.

First to the menus. You can edit any menu at Appearance -> Menus. At the right side of this screen you should see a flag with a small "+" icon to translate your menu to English.

Menus need to be translated in this section only. After translating your menus please make sure to select the option "sync menus between languages". You might also do this by going to WPML -> WP menus sync.

Please find a detailed documentation here:

https://wpml.org/documentation/getting-started-guide/translating-menus/

About the second issue regarding your images I would advise you to use our plugin Media Translation which is especially dedicated to sync different images for different languages. You can download it by login into your https://wpml.org/ account.

https://wpml.org/documentation/getting-started-guide/media-translation/

You also might verify if your English content is a duplicate of the Dutch content. this might lead to issue when updating content in different languages.

https://wpml.org/documentation/translating-your-contents/displaying-untranslated-content-on-pages-in-secondary-languages/using-content-duplication/

Also to help you faster, I've enabled debug information for this support ticket. Please see this link for how to get this information from your site and give it to us:
http://wpml.org/faq/provide-debug-information-faster-support/

Please let me know if you need any further assistance.

Best regards,
Andreas

December 22, 2018 at 1:56 pm #3027545

susanV-3

Hi,

The problem is that when i do anything on the english page (text, photo or anything) it doesn't show on the front. When i go back to that page in wordpress, it's back to how it was. It seems that it just doesn't save..

Also the problem with the menu stays, i can't get it right.. In dutch it's like i want it to be, but the english one wont go like that..

December 22, 2018 at 2:02 pm #3027562

susanV-3

The menu issue has been solved :)!

December 26, 2018 at 4:08 pm #3034512

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi!

I would like to take a closer look at your website but the login credentials provided on the previous ticket are not valid anymore.

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

IMPORTANT

Please make a backup of site files and database before providing us access.
If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

Best regards,
Andreas

December 26, 2018 at 4:10 pm #3034517

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi!

Additional to my last email.

Could you please increase your Memory Limit and WP Memory limit to 256M? 128M is the minimum required by WPML.
Your current values are:

MemoryLimit 256M
WP Memory Limit 40M
Add this code to your wp-config.php to increase WP memory:

/* Memory Limit /
define('WP_MEMORY_LIMIT', '256M');

Paste it just before:

/ That's all, stop editing! Happy blogging. /

These settings can be limited directly by your hosting provider, so I recommend you to contact and ask them to modify them directly.
If you can get even higher values It would be great.

https://wpml.org/home/minimum-requirements/
Note: WPML needs a minimum WP Memory limit of 128M to work only under a minimal environment, it means,
with a default theme and not other plugins installed.

Best regards,
Andreas

December 27, 2018 at 2:14 pm #3037176

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi!

I have sent you a private message with access details for our test server. It would be very helpful if you could migrate your website for further debugging.

Kind regards
Andreas

January 4, 2019 at 3:22 pm #3057020

susanV-3

Hi Andreas,

I guessed i missed a few messages, so sorry. The problem with the pages not translation is still on. What do i need to do now?

January 4, 2019 at 6:14 pm #3057502

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi!

I just sent have you a private message with instruction to migrate your site to our test server.
Please also give me again some detailed steps about the issues.

Were you able to solve the image issue with our Media Translation Plugin? Are translation still not saved and available on frontend? Does this affect on old posts/pages or also on new ones or both?

Please make sure to migrate your site for further debugging or only provide us new login credentials as the old ones were not working.

Kind regards
Andreas

January 4, 2019 at 10:05 pm #3057976

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi!

I was able to log into your website and I realized that when editing a page with the default native WordPress Editor the visual content of your page builder does not match the actual site content. Further, when editing a text field the visual text mode does not respond.

It is unclear to me if this is related to your theme or WPML. Could you please disable WPML for a moment to see if the issue persists.

Further, I would kindly advise you to update WPML and its add-ons to the latest version to see if the issue had been fixed in one of our latest updates. Please go to Plugins -> Add New -> Commercial tab and update and activate the WPML plugins.

Now I can see that when going to Pages and selecting NL, then clicking on the "+" icon for the English translation of the "KUSSENS" page you are able to edit the text you are referring to. We do always advise to use the WPML Translation Editor when working with page builders like Avia (Enfold) to maintain the compatibility.

https://wpml.org/documentation/support/maintaining-avia-layout-builder-enfold-compatibility-wpml/

Further, I can not find any image items inside the Translation Editor as in here those images should be available and copied or replaced as well. Could you please install our Media Translation Plugin. This plugin is mandatory if you wish to used different images on your translated content.

Please let me know if you need any further assistance.

Kind regards
Andreas

January 5, 2019 at 11:30 am #3058918

susanV-3

Hi,

Still doesn't work.. As you can see i changed the pictures in the back, but when i take a look at the website, it's still the old picture.. Also i updatet all the plugins and installed the media translation..

January 7, 2019 at 2:35 pm #3063181

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi!

Thank you for your message.

Did you try to translate the images with Media Translation? Please have a look at the following documentation and let me know if this solved the issue.

https://wpml.org/documentation/getting-started-guide/media-translation/

It might be that there is a problem with the image URLs. Could you further try to add the files again to the page and then translate them with Media Translation.

Also if possible please try if the issue persists if you disable any plugin that is not related to WPML or WooCommerce.

Further, to have a more detailed look at the issue we would need to migrate your site to our test server. Sadly you told me that the migration failed. I connected to your website again to save a backup for installation of your site on a localhost environment. It was not possible to create the package. Please see the screenshot attached and let me know if you could disable "PHP Open base Dir" for this purpose.

Kind regards
Andreas

Kind regards
Andreas

January 12, 2019 at 10:29 am #3082978

susanV-3

I tried to delete the pictures from the media and then upload them again. I tried this on the page 'plaids'. I inserted them on the dutch page, then went to media translation and uploaded the engish pictures. Now the pictures aren't showing on the english page. This is really a disaster because my english custumors can not see anything and not order.. Please please help me.

January 14, 2019 at 3:14 pm #3088361

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi!

Thank you for your answer.

By logging into your site I realized at WPML -> Media Translation that at least one item is not added to the correct language. I found an English Image for the page "plaits" which was added for Dutch language. Further, the respective English image is not yet translated.

Please see screenshot attached.

In case you need to replace an image please make sure to add the respective image to your default language and then add a second image for the second language on Media Translation.

Please translate the missing images on WPML -> Media Translation. Then please go to WPML -> Settings -> Media Translation and click the "Start" button to sync and duplicate images automatically.

I really hope that this solved your issue. Please let me know if you need further assistance.

Kind regards
Andrea