This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by Andreas W. 8 months, 1 week ago.

Assigned support staff: Andreas W..

Author Posts
February 11, 2019 at 6:38 pm #3184961

linaR

I am trying to:
The translator works without problem in the upper level pages that are added in the main menu of the second language, which in our case is English. When I navigate to the secondary pages, the main menu does not save the variable lang = x in the url and therefore when using the buttons of the main menu it sends me to the correct page but in the main language without lang = x in the url. Should any special implementation be made to the menu created for the second language regarding these secondary pages?

Link to a page where the issue can be seen: hidden link

I expected to see:

Instead, I got:

February 11, 2019 at 7:05 pm #3185074

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi,

Thank you for contacting WPML Support.

The language switcher on the provided page is not showing any language options. Is the page translated completely? Please go to "Pages" and translate the content.

Also you might consider to change the site URL structure. You may choose different directory for each language at WPML -> Languages -> Site URL structure. You are also able to set a directory fort eh default language.

Example:
hidden link (Spanish)
hidden link (English)

Now, please go to Settings -> Permalinks and simply click the save button.

Let me know if this solved the issue.

Kind regards
Andreas

February 11, 2019 at 7:37 pm #3185216

linaR

Hi Andreas,

Thank you so much for your response. The issue is: all the website is already translated to english, including secondary pages as: News and the Bios of the team. When I click one of the news, or the bios, the site goes to a secondary page, and if I try to click on the menu (in the english version) it will send me to the website in spanish. (Please see the image attached). Help! please let me know what I'm doing wrong.

February 11, 2019 at 8:18 pm #3185351

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi,

Do I understand right, that the homepage is translated into English but it will not show up on Front End?

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

IMPORTANT

Please make a backup of site files and database before providing us access.
If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

Kind regards
Andreas

The topic ‘[Closed] menu and secondary pages’ is closed to new replies.