This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Please make sure to update to WPML to the latest and check our list of Known Issues before reporting

This topic contains 6 replies, has 2 voices.

Last updated by dimitriosM-2 3 years, 3 months ago.

Assigned support staff: Lauren.

Author Posts
December 7, 2016 at 11:40 am #1153699

dimitriosM-2

Hello,

I'm facing a problem with the menus. When I change language from language switcher, the pages are getting changed correctly but the menu doesn't change.

I re-created the menus like 10 times.
First tried to create only the English menu and pressed the Sync menu button.
After it didn't work I deleted all menus created again the English ones and with the blue + button I created the linked one for French. It also didn't work.

Its the first time I experience this issue as I used wpml for alot of websites.

Have any idea what the issue could be ?

Website: hidden link

Thanks in advance

December 7, 2016 at 6:19 pm #1154229

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thank you for contacting WPML support. I'll be happy to help you with this.

I understand that your menus is not changing when you switch languages on your site. First, please try increasing the WP Memory Limit. Minimum requirements are 128Mb: https://wpml.org/home/minimum-requirements/

You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

Add it above the line /* That's all, stop editing! Happy blogging. */

Next, if you have any ajax options in your theme, try disabling them in case your menu is being displayed using ajax, it may not be refreshing when the language changes.

Lastly, if those don't work, I'd like to have you try a few things so we can try to isolate the issue. This is just to help me identify if it might be a conflict with another plugin or theme that is causing the problem.

** IMPORTANT ** Please backup a working copy of site files and database before continuing.

Update all WPML plugins & WordPress core.

Disable all plugins except WPML related and then temporarily change the theme to a default WordPress such as TwentyFifteen. Does this resolve the issue?

December 8, 2016 at 8:37 am #1154603

dimitriosM-2

Hello,

The Memory Limit + ajax options didn't work
After Disabling all plugins and changing theme to Twenty Fourteen the language switcher disappeared.
Altough if I change the url using /fr/ or leaving it empty, the menu seems to change without an issue.

December 8, 2016 at 4:43 pm #1155238

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

When you switch to a default theme, you will need to assign your main menu and add the language switcher to the main menu in WPML -> Languages. Since the menu seems to be working fine in Twenty Fourteen, it is most likely a theme compatibility issue.

This does happen with certain themes that are not compatible with WPML
=>https://wpml.org/documentation/theme-compatibility/

Unfortunately the easiest way to get around it is switching to a compatible theme or a default theme ex. twentyfifteen

If switching to a default theme is not an option , then we will need to contact the theme author and work with him on resolving the issue and making the theme Compatible.

Please provide a link to your theme (you can zip it and upload it Google Drive or Dropbox and then post the link in the next reply) as well as an email address for the theme's author so we can contact him. I will mark the next reply as private so this information will remain secure.

I will forward the details to our Themes & Plugins Compatibility Team and they will contact the author.

Please note that this process may take a while as it depends on how soon the author will reply to our efforts to contact him.

It would be great if you can also contact the author asking him to reply us. You could also refer them to our Go Global program so that we can help them make their theme compatible with WPML. https://wpml.org/documentation/theme-compatibility/go-global-program/

This may help expedite the process.

December 9, 2016 at 9:49 pm #1156555

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thank you for sending this download link. I uploaded this theme to a test version of my site and when I use the language switcher to change languages, the menu items change to the secondary languages along with the content.

So, I would like to get a copy of your site that I can set up locally for further testing. Please make a snapshot of your site using the Duplicator plugin: https://wordpress.org/plugins/duplicator/. Once the snapshot is complete, either upload the snapshot ZIP file and the installer.php file to a file sharing service such as Dropbox (and share the link in your reply) or right click the Duplicator links in your wp-admin and paste in your reply.

Please note: It is important to reduce the size of the package so please exclude some paths like /cache or /uploads and also exclude archives and media files.

I will enable the next reply to be private so only you and I have access to it!

December 12, 2016 at 4:29 pm #1158026

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thanks for sending credentials to your test site. When I switch from English to French and vice versa, the main menu items change to their respective languages. Is there a different menu that you are referring to?

December 13, 2016 at 7:41 am #1158507

dimitriosM-2

I gave the credentials to the theme company too before some days and they found the issue and fixed it! Thats why you saw the menu working properly!

Thank you very much for your time and your help I really appreciate that!