This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: Menu in A different domain per language Solution: "Found it! itheme security plugin was doing this! just disable it and works...if i enable this problem occurs "

Tagged: 

This topic contains 17 replies, has 4 voices.

Last updated by alexV-23 1 month ago.

Assigned support staff: Bruno Kos.

Author Posts
September 10, 2019 at 7:57 am

alexV-23

I am trying to: A different domain per language

Link to a page where the issue can be seen: hidden link

I expected to see: Greek menu

Instead, I got: this menu does not exist

if i select hidden link i see the right menu and the right home page
if i select different domain i see a menu that does not exist ( i rename contact to contacts in En site to test this )

September 10, 2019 at 8:11 am
September 10, 2019 at 8:39 am #4543187

alexV-23

Hi someone send me a chat message i can't find it.
yes i try to use different domains per language

September 10, 2019 at 10:33 am #4544233

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hi There,

within WPML->Languages->URL Format you can set up different domain per language
-> https://wpml.org/2016/04/use-wpml-different-domains-per-language/

also to set up a different menu per language you can do this by going to Appearance->Menus->and add a translation to your menu

September 10, 2019 at 10:41 am #4544293

alexV-23

Hi Bobby i know the process

i have 2 menus
one English and one greek - translation of the English

if i choose Greek language to be robotixlab.com/el everyhting is perfect
if i choose Greek language to be robotixlab.gr then it show a menu that i don;t know where it comes. It is not the English or the Greek menu

for example.

in english the contact menu item send you to a new page

in robotixlab.gr send you to an anchor text ( Like it was in the past )

in admin the greek menu it is called " επικοινωνια "

September 10, 2019 at 10:43 am #4544297

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

If possible i would like to take a closer look at the backend to further test this issue

**Before we proceed I recommend to please take FULL BACKUP of your database and your website.**
I often use the Duplicator plugin for this purpose See: http://wordpress.org/plugins/duplicator/

I would like to request temporary access (wp-admin and FTP) to your site to fix the issue.
(preferably to a test site where the problem has been replicated if possible)

You will find the needed fields for this below the comment area when you log in to leave your next reply.
The information you will enter is private which means only you and I can see and have access to it.

NOTE: if access to the live site is not possible and staging site does not exist please provide me with a duplicator package created with the duplicator plugin

September 10, 2019 at 12:39 pm
September 10, 2019 at 6:32 pm #4548143

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Thank you for the access details !

When i switch the URL Format to permalinks it works as expected

If you notice , with the URL Format set to different domain per language even if you make a small change in the menu it will not be displayed in the front end almost as if there is some sort of caching

from the side of WPML i can confirm that this is not a known bug. I believe there is something set up wrongly for the different domains, if possible please verify that everything is set up well and also recommend getting some feedback from the host provider as well

Note : I checked for any redirects and i get the following under your greek domain

<em><u>hidden link</u></em>

HTTP/2 301 
date: Tue, 10 Sep 2019 18:31:54 GMT
server: Apache
x-redirect-by: WordPress
vary: User-Agent
location: <em><u>hidden link</u></em>
content-length: 0
content-type: text/html; charset=UTF-8

<em><u>hidden link</u></em>
September 11, 2019 at 7:41 am #4551149

alexV-23

HI Bobby there is no cache except the wordpress cache
the menu that is shown in .gr does not exist! is not the same with EN or the GR
i added the .gr by cpanel ( send you the username password ) with the alias domain ...

September 11, 2019 at 8:00 am #4551229

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

please note the redirect i have provided above, also the issue is resolved when using a different URL format therefore there is an issue with the different domains.

this is not a known issue and i am also not able to reproduce on a staging environment

we simply provide the functionality to be able to use different domains per language , but the set up of it is controlled by your side and your host, if possible i would suggest involving them and getting their feedback on this issue as well

September 12, 2019 at 9:43 am #4559869

alexV-23

your documantation says about parked domain. this was changes will alias now right? cpanel has park domain anymore...

but what you say doesn;t make any sense... why using .gr domain shows a menu that does not exist? where this menu comes from?

September 13, 2019 at 8:30 am #4566579

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hello and thank you for your patience.

As my colleague, Bobby is not available right now, I would be more than happy to step in and continue the support process in this ticket.

I hope that is ok with you, too (please let me know if it's not).

Now, looking over the ticket, over the conversation and the work that was done here by my colleague, may I kindly ask you to please get in touch with the hosting company and see if there is any caching or some other script/scripts that are coming from their side?

From what Bobby said, I can see that he found an alternative to make things work but unfortunately, there would be nothing else that could be done from our side that was not tried already regarding this issue.

The servers and the scripts that are used by hosting companies differ a lot from each other and there's really no way we could know exactly what is the issue as we don't have control over the servers, but only guess, that is why I recommend that you get in touch with the hosting company that has full access to the servers and to the server configurations.

Please let me know how that goes.

Kind regards,
Mihai Apetrei

September 13, 2019 at 8:40 am #4566609

alexV-23

Hi Mihai ,
i know that using other method than different domain is working , i wrote that on the ticket.
i am the admin of the host so there is no cache from server side...
it is a simple cpanel server where for example in giousouri.gr is working as expected.
what is strange is that the menu in robotixlab.gr does not exist! there is no menu in backed similar to this....

September 13, 2019 at 4:12 pm #4570005

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for your response.

Let's try a few more things:

1. Please create a full website backup

2. I have noticed that your website’s WP Memory Limit is 40MB. The WP memory limit needs to be increased as the minimum requirement for WPML is 128Mb WP Memory Limit: https://wpml.org/home/minimum-requirements/

❌ Very important: please make a backup of your site (files & database) before following any of the upcoming steps ❌

Please add this to your wp-config.php file to increase WP memory:

/* WP Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

Paste it just before:

/* That's all, stop editing! Happy blogging. */

These settings can be limited directly by your hosting provider, so, if that’s the case, I recommend you to contact and ask them to modify them directly. If you can get even higher values It would be great.

Please make sure you have updated the values successfully, You can verify them from WPML >> Support page.

3. Then go here (hidden link) and update everything to the latest version. After that, please see if the issue is still happening.

4. If that doesn't change anything, can you please go to WPML > Support > Troubleshooting and press the following buttons:

- "Clear the cache in WPML"
- "Remove ghost entries from the translation tables"
- "Fix element_type collation"
- "Set language information"
- "Fix terms count"
- "Fix post type assignment for translations"

5. Now please see if anything changed.

Please let me know how that goes.

Also, can you please check there is no custom coding in your functions.php file or .htaccess file?

I will be waiting for your response.

Kind regards,
Mihai Apetrei

September 16, 2019 at 10:21 am #4578787

alexV-23

HI, i did all of them.
the same
.gr show a menu that does not exist ( it was the previous English menu... )

it is as it takes wrong orphan laguage...