This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by anna-michelaC 11 months, 3 weeks ago.

Assigned support staff: Riffaz.

Author Posts
October 29, 2018 at 2:48 pm #2858469

anna-michelaC

Tell us what you are trying to do? Add an icon to switch language (from default English to Czech) in my primary navigation (top right)

Is there any documentation that you are following? No

Is there a similar example that we can see? n\a

What is the link to your site? hidden link

October 30, 2018 at 5:46 am #2860514

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi Anna,

Thank you for contacting WPML support.

May I ask that have you set up the menu language switcher in WPML > Languages > Menu Language Switcher? : hidden link

If not, please refer: https://wpml.org/documentation/getting-started-guide/language-setup/language-switcher-options/#separate-sections-for-different-kinds-of-language-switchers

Regards,
Riffaz.

October 30, 2018 at 9:05 am #2860903

anna-michelaC

Hi Riffaz,
thanks for your reply.

Yes, I have done that - please see screenshot

October 30, 2018 at 12:23 pm #2861612

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi Anna,

As per your settings and debug info the switcher should show up but it does not show up.

Anyhow, it seems like an incompatible issue as well.

Plugin conflict
Could you please disable all the plugins and check this?

Minimal Setup
If you disable all non-related WPML plugins, switch to one of the default themes like twenty seventeen, the problem persists or not?
NOTE:
+ Make a backup (both files and database) for your site before updating/proceeding anything (Always a good practice!).

Let me know the results, please.

Regards,

October 31, 2018 at 9:41 am #2865043

anna-michelaC

Hi there. No, it didn't work...disabled all plugins and reverted to the default 2017 theme but noting still

October 31, 2018 at 11:24 am #2865499

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi Anna,

This is really strange.

Could you please let me know your site login details to check this closely?
I am setting the next reply as private.
So only you and I can see the next reply.

Regards,