This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by Mélanie Couture 2 months, 1 week ago.

Assigned support staff: Noman.

Author Posts
July 30, 2019 at 3:41 pm #4309361

Mélanie Couture

Tell us what you are trying to do?
Nous aimerions inverser la langue dans le menu de notre client. Quand nous sommes sur le site anglais, on voudrait que le choix soit écrit Français et vice versa. Présentement c'est la langue actuelle qui se trouve au menu. Les gens doivent mettre leur souris pour savoir que c'est un menu pour choisir une autre langue. J'ai fouillé dans tous les paramètres et je n'ai rien trouvé.

Is there any documentation that you are following?
Je n'ai pas trouvé.

Is there a similar example that we can see?
Voir fichier attaché

What is the link to your site?
hidden link

July 31, 2019 at 4:16 am #4311403

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML support. I am going to answer this in English, I hope that is ok, if you still need help in French please let me know.

You can hide current language from language switcher by unchecking ‘Current language’ checkbox from WPML >> Languages >> Menu language switcher / Custom Language Switcher as you can see in the attached screenshot. Here is doc for more details:
https://wpml.org/documentation/getting-started-guide/language-setup/language-switcher-options/

Please let me know if this resolves your issue or you need further assistance with this issue.

Thank you

August 5, 2019 at 11:44 am #4340155

Mélanie Couture

No, I can't. This option isn't available, it's in gray (see attachment).

August 5, 2019 at 1:15 pm #4340743

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

It seems you have selected dropdown option that's why ‘Current language’ option is disabled. Could you please select ‘List of languages’ option and I hope then ‘Current language’ option will be enabled.

Please let me know if this resolves your issue or you need further assistance.

Thank you

August 5, 2019 at 3:37 pm #4341691

Mélanie Couture

My issue is resolved now. Thank you!

I tried to "List of languages" but I saw French and English in my menu. I didn't want both in my menu. I forgot to disable "Currect language" at this time.

Finally, my problem was ridicule. I'll open my eyes next time LOL