This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 14 replies, has 2 voices.

Last updated by Itamar 1 month, 3 weeks ago.

Assigned support staff: Itamar.

Author Posts
August 17, 2019 at 8:08 am

gabrielP-16

Hello Dear,
please find the video.
hidden link

when you are in SHOP page and click on (Language bar) to change language...
its not Linked with Correct URL(not working)

but in reality the second language shop page is exist and when you click direct on shop(second language) when you are in second language homepage..its working properly.

please advice.

August 18, 2019 at 7:13 pm #4412659

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

Issues like that might occur when you switch the default language of the site. Currently English is the default language of the site. Was French the default language of the site previously?

Could you please share your Debug information with me?
You can read the detailed explanation about it here.
http://wpml.org/faq/provide-debug-information-faster-support
The debug info will give me a lot of information about how your site is configured and will help me understand the source of the problem.

Thanks,
Itamar.

August 18, 2019 at 7:30 pm #4412671

gabrielP-16

Hello
No i didnt change defualt language...
also i was provide the login detail for the admin part

Regards

August 19, 2019 at 4:21 pm #4417437

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

Thanks for confirming that you didn't change the default language. However, I see somethings weird on your site. When I go to Pages -> All Pages in English, I can see that the name of your shop page is 'Boutique' and it is not translated into French and Arabic. Please see the attached screenshot boutique-in-en.jpg. The URL of the shop page of your site in English is this.
hidden link
When I use the Language Switcher on this page and switch to French, I get this.
hidden link
And for Arabic, I get this.
hidden link
Which seems correct.

When I go to Pages -> All Pages in French I see that the shop page is called Shop and is translated into English and Arabic. Please see the attached screenshot fr-shop-page.jpg.

I think that what you should do in this case is to delete the shop page in French its translations. And then change the name and slug of the shop page in English (currently Boutique) to Shop. The translate to French and Arabic.

**** Important! Please make a full site backup (files and DB) before you proceed with those steps****

Please let me know if this information is helpful to you.

Regards,
Itamar.

August 21, 2019 at 9:26 am #4429397

gabrielP-16

Hi
i did all what you mention, also try more task things from my side.
but at the moment, if you are in shop(English) and click translation to french(same problem)
but the strange point is...if you are in shop(french) and click translation to English...its redirected successfully to English shop page !

please advice.

August 21, 2019 at 9:42 am #4429651

gabrielP-16

Its happens new strange point (without changing any thing on admin)

the shop(French)/ page in menu (french site) disappear .....
this happen when you are in English website and then go to french website (using language bar) , or direct if you login throw hidden link

but in reality this page is there, also in menu available if you login from diffrent way. like direct to the page :

hidden link

*I think this point its not related to the Setting of WPML and need Technical support from WPML to looking for the code.

anyhow waiting for fast action

Regards,

August 22, 2019 at 9:57 am #4438219

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi and thanks for trying my suggestions.

I can see that the issue still exists. When I go to hidden link and switch to French to Arabic, I get hidden link again. Please follow the next instruction to try and correct this issue.

1. Take a backup of the DataBase of your site.
2. Go to WPML -> Support -> Troubleshooting (link)
Once on the troubleshooting screen press the following buttons and check if it helps.
Press each button at a time and wait for the process to complete.
- 'Disable cache for language switcher templates'
- 'Clear the cache in WPML'
- 'Remove ghost entries from the translation tables'
- 'Set language information'

*** Please make a backup of your database before using this.***

You wrote: "the shop(French)/ page in menu (french site) disappear .....
this happen when you are in English website and then go to french website (using language bar) , or direct if you login throw hidden link"

I cannot see this problem. When I go to hidden link I see the 'BUTIQUE' menu item. Please see the attached screenshot. Have you fixed this issue already?

Thanks,
Itamar.

August 22, 2019 at 3:08 pm #4440707

gabrielP-16

HI,
I did all the troubleshooting points.
still the problem same...
please advice.

**regarding the part 2...yes its solved its available in french menu.

Regards,

August 25, 2019 at 10:35 am #4453885

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi and thanks for trying my suggestions.

I can see that you are using the W3TC cache plugin. This plugin is compatible with WPML. But it has a lot of settings. When I clear the cache from the plugins options, the problem is resolved. Please see the attached screenshot. But the problem is that the issue is then coming back. Please review our documentation on how to work with WPML and the W3TC plugin at the following link.
https://wpml.org/documentation/plugins-compatibility/optimize-multilingual-website-performance-using-w3-total-cache/
Please make sure that all the settings are configured correctly.

Thanks,
Itamar.

August 25, 2019 at 12:18 pm #4454023

gabrielP-16

Hi,
its look like that the documentation link its not updated, as the information are not set and match with updated w3TC plugin.
*i try to disable the plugin and the update the wpml (trubleshooting) still the problem not solved.
**also i clear the catch of the w3tc and try , the problem is same.

please advice.

August 26, 2019 at 3:45 pm #4460225

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

I would like to continue debugging this issue on our test server. See the next private reply with all the details on how to migrate your site to our server. The process is quite easy.

August 26, 2019 at 3:46 pm
August 26, 2019 at 4:06 pm #4460283

gabrielP-16

i think it will take alot of time ? maybe 8-12hours? for 15GB?
if your test will not take mroe than 1-2 hours, i can make backup easily and do your test in our website direct

August 27, 2019 at 12:52 pm #4466809

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

I do not want to risk your live website. But if you can create a staging site on your server with a copy of the live site, then I can continue and check things there. Then we will not take the risk of breaking your live site. If needed I'm enabling a private message for the next reply.

Thanks,
Itamar.

August 30, 2019 at 5:11 am #4484745

gabrielP-16

i coudnt do the staging...
i will migrate the website on the test server soon

The topic ‘[Closed] Menu (shop) trasnlation URL link not working’ is closed to new replies.