This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by Noman 5 months, 2 weeks ago.

Assigned support staff: Noman.

Author Posts
April 30, 2019 at 10:48 am #3710401

cannac

Hi,

I have an issue when i'm on an article i can't change the Language in the menu.

The language switcher doesn't work only work on index.

Check : q8.news

Thanks

April 30, 2019 at 10:53 am #3710473

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support. Could you please make sure you have translated your site articles completely as it is necessary, the contents you are viewing on the front-end must be translated. You can translate one page yourself to see if the language switcher appears correctly.
https://wpml.org/documentation/beginners-guide-to-site-translation/

If still issue persists, please add the debug report in the Debug Information box. I have also enabled debug info box for your next reply: https://wpml.org/faq/provide-debug-information-faster-support/

Thank you

April 30, 2019 at 11:02 am #3710525

cannac

Hi,

i mean about the menu .

when i click on article i can't see the language switcher at all it has no relation with translations.

see q8.news

when you click on article
hidden link

when i have the menu i want to go to the index if i change on arabic go to eng , if im on eng go to arabic

April 30, 2019 at 1:14 pm #3711333

cannac

string translation option is disabled. how i can enable it ?

thanks

April 30, 2019 at 5:30 pm #3713935

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

If you have translated your site posts and pages and still language switcher not showing secondary language flag then please follow below steps to isolate the cause of the issue.

- Backup your site first before making any change, this is for security reasons.
- Please make sure minimum requirements for WPML meet:
https://wpml.org/home/minimum-requirements/

- Please make sure your theme is WPML compatible. Here is our compatible theme list. You can search your theme in this list. https://wpml.org/documentation/theme-compatibility

- Also make sure you are using an updated version of the theme and plugins.
- Deactivate all the plugins that are not related to WPML.
- Switch for a moment to a WordPress default theme like Twenty Seventeen.
- If the issue is gone, activate one by one to see which one there is an interaction issue.

Please let me know the results.

string translation option is disabled. how i can enable it ?

Please make sure you have installed and activated WPML String Translation plugin:
https://wpml.org/download/wpml-string-translation/

Thank you

The topic ‘[Closed] Menu Switcher’ is closed to new replies.