Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 2 replies, has 2 voices.

Last updated by Carlos Rojas 1 year, 11 months ago.

Assigned support staff: Carlos Rojas.

Author Posts
July 15, 2019 at 3:17 pm #4212751


I am trying to: I updated the website, switching to english as default language

Link to a page where the issue can be seen: hidden link

I expected to see: Language switcher as last element of the upper menu, as it showed before my update

Instead, I got: nothing, no switcher whatsoever

July 15, 2019 at 3:35 pm #4212873

Carlos Rojas

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Thank you for contacting WPML support.

I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Kind regards,

July 15, 2019 at 8:09 pm #4214493

Carlos Rojas

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hi Max,
Thank you very much for the information provided.

I went to WPML -> Languages -> Menu language switcher -> And added the language switcher to the menu.

You can modify the language switcher following the same steps.

Could you confirm that the issue is solved?