This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 14 replies, has 3 voices.

Last updated by bredaM 1 week, 6 days ago.

Assigned support staff: Riffaz.

Author Posts
September 18, 2019 at 4:07 pm #4598639

bredaM

Hi,
I am struggling with WPML, on this website:hidden link

If you scroll to the footer you'll see english and russian.
1st problem is when I switch to Russian some of the menu links are not showing, those the are showing for example in the footer menu if you click on Terms and Conditions in the russian version you get product not found. But the Russian page is there, when I preview it from the admin it brings up the same product not found?

hidden link

2nd problem is I can't edit any pages made with elementor, do I need to do something to allow this? I want elementor to stay in english but be able to edit the russian pages using it.
thanks
Breda

September 19, 2019 at 3:52 pm #4607013

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

I'm trying to understand the issues that you are having.

1.
I can see that on the Russian page at the following link the links under 'Categories' and 'Information' in the footer are missing. Please see the attached screenshot categories-and-information.jpg.
Is this one of the problems that you are having?
If so, then please specify how you have inserted those link in the footer.
If they inserted with widgets, then please refer to our documentation at the following link.
https://wpml.org/documentation/getting-started-guide/translating-widgets/
https://wpml.org/documentation/getting-started-guide/translating-widgets/displaying-different-widgets-for-different-languages/

2.
The issue with the Russian TERMS AND CONDITIONS OF USE page here.
hidden link
I can see that it says in Russian the following.

Товаров, соответствующих вашему запросу, не обнаружено.

Which in English means.

No products were found matching your request.

This is very weird because it does not seem that the TERMS AND CONDITIONS OF USE page suppose to display any products.
Are you expecting to see any products on the Russian page?

3.
Elementor issue.
Can you please confirm that you are following our instructions at the following link on how to work with WPML and the Elementor plugin?
https://wpml.org/documentation/plugins-compatibility/elementor/

Thanks,
Itamar.

September 19, 2019 at 4:04 pm #4607147
bredaM

Hi Itamar,
1. no I am talking about the primary menu, if you look at the home page in english you'll see about 8 menu items, when you switch to Russian there is no menu displayed at all, even though there is a primary menu for Russian. The Russian home page is linked to the English one when I go to the page I can see it. Can I give you a log in?

2. No the terms and conditions page in russian should be the same page format as the english one, no products just text.

3. we seem to have elementor working for the russian pages but its using a russian interface, would be easier if we could set it to English.

thanks
Breda

New threads created by Itamar and linked to this one are listed below:

https://wpml.org/forums/topic/split-terms-and-conditions-page-is-showing-differently-on-the-other-language/

September 19, 2019 at 7:25 pm #4608147

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi Breda.

1.
OK, I can see the missing menu in the Russian version. Please see the attached screenshot.
It seems related to the settings of the theme. Please explain to me how and where you are configuring the header of your theme. Sometimes screen-shots illustrating what you mean may go a long way to clarify what words fail to transmit, so if you like, make use of “upload an image” below the comment area.

If you need further help with this, please share the access details to your site with me.
I'm enabling a private message for the next reply.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- - Please make a backup of site files and database before providing us access. --

Thanks,
Itamar.

September 22, 2019 at 12:55 pm #4618589

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi, Breda and thanks for the access details.

Here is what I tried on the Appearance -> Customize -> Menus -> Primary Menu.
Before entering the Customize section, I switched the language flag at the top admin bar to Russian. Then when I entered this section, I could see that the 'Primary Menu' checkbox is not checked. Please see the attached screenshot. If I enter to this section when the English flag is chosen, the box is checked. So I've checked the option and saved the changes. This, unfortunately, did not solve the issue.

The Shoptimizer theme by CommerceGurus is not officially compatible with WPML. I couldn't find it on our list here.
https://wpml.org/documentation/theme-compatibility/
And I couldn't find anything about this theme in our internal records.
So to continue debugging this issue, we need to replicate it on a clean WordPress installation.
For this, I created a test website with a clean WordPress install. You can access it through this link:
hidden link
Through this link, you will be automatically logged in. (If nobody logs in the test site will be available for one week from today.)
Could you please install the Shoptimizer theme and see if the issue is replicable on a clean WordPress installation?
Please configures WPML as it is configured on your site.
Please also make sure that you are installing the latest version of the theme.

If the issue is replicable in the sandbox site, then I'll escalate it to our compatibility team, and they will try to find a fix for the issue.

FOr the Elementor issue, you will find a new ticket.

Thanks,
Itamar.

September 23, 2019 at 11:02 am #4622693

bredaM

Thanks Itamer,
I installed the theme on your demo site and put in a simple menu. It seems to be working ok. I must have some thing in the configuration wrong, I can't see what it is.
thanks
Breda

September 23, 2019 at 7:44 pm #4626389

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi, Breda.

First, please re-save the menu in English and then its translation in Russian. Then please go to WPML -> WP Menu Sync and sync the menus if needed. If it does not help, then please see if the issue persists in a minimal environment.

I suspect that there is a collision with the theme or another plugin that might cause this problem. If possible, get your site into a minimum environment. Minimum environment means switching to a default WordPress theme like TwentyNineteen and no plugins activated except WPML. You will need first to check if the problem persists when just the theme is switched to TwentyNineteen (for example). If it persists then deactivate all plugins except the WPML and its add-ons and WooCommerce itself. Then please check if the problem persists. If it does not persist, so start by activating the plugins one by one and check when the problem comes back, then report to me which was the culprit plugin.

**** Important! Please make a full site backup (files and DB) before you proceed with those steps****


*** If your site is a live site you might want first to try those procedures in a staging environment or a snapshot of your site on your local server or another server. ***

FYI, I've tried to log in to your site to check things, but I couldn't log in. If you changed the credentials, please share the new credentials with me. You can edit the previous private message.

Thanks,
Itamar.

September 24, 2019 at 7:55 am #4628745

bredaM

Hi Itamar,
I have reset the password to the same one as the private message, hoepfully that works now.
I have switched to the theme tentynineteen and the Russian menu does not show. I will go through the steps you said and try again.
thanks
Breda

September 24, 2019 at 8:52 am #4629291

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

OK, Breda.

I'll wait for your reply.

September 26, 2019 at 2:32 pm #4647745

bredaM

Hi Itamar,
We found the plugin that was stopping the main menu from loading on the home page when we changed to Russian. The translated menus are now appearing on the Russian homepage however, we are still having some problems in regarding the translated menus. Any normal page link seems to be working fine but any menu link that is a product-category, now sends you to a broken link, as seen in the screenshot below:
hidden link

Can you log in and take a look for me please?
thanks
Breda

September 27, 2019 at 10:58 am #4653635

bredaM

Hi Itamar,
I am supposed to put this website live on Monday morning, can you have a look at this for me please?
thanks
Breda

September 28, 2019 at 6:08 pm #4658895

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi, Breda.

Could you please send me the link or specify the menu items that are not working?
I've just tried a few of the menu items in Russian that are products categories and they seem to work fine. Here are a few of the links that I've tried.
hidden link
hidden link
hidden link
Please see the attached screenshot.

The following link to our documentation might be helpful for you in this case.
https://wpml.org/documentation/getting-started-guide/translating-menus/

Regards,
Itamar.

September 30, 2019 at 9:16 am #4663223

bredaM

Very strange, its working now!
I might leave this open just in case it stops working again,
thanks
Breda

October 1, 2019 at 10:42 am #4671111

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Great, it works now.

Please close this ticket and open a new ticket if you have any other question.

Regards,

October 4, 2019 at 7:44 am #4693499

bredaM

My issue is resolved now. Thank you!