Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problème: Je souhaite que la racine du domaine redirige vers la langue par défaut située dans un répertoire, comment faire ?

Solution:
Lorsque les options "Langues différentes dans les répertoires" et "Utiliser le répertoire pour la langue par défaut" sont sélectionnées, il faut définir la page qui s'affichera à la racine du domaine.

Si l'on souhaite que la racine du domaine redirige vers la langue par défaut, il est possible d'utiliser un modèle de page qui n'effectuera qu'une redirection. Voici le modèle de page proposé :

<?php
/*
Template Name: Root redirect
*/
wp_redirect( home_url() );
exit;
?>

Ce fichier que l'on pourra nommer "page-root-redirect.php" sera à placer à la racine du répertoire du thème.

Il faudra ensuite sléctionner l'option "Une page" pour "Ce qu'il faut afficher pour l'url racine :". Enfin cliquer sur "Créer la page racine".

Dans l'éditeur de page de WordPress, il faudra sélectionner le modèle de page précédemment créé.

Modifier la page ‹ MDL — WordPress.png

Désormais, la racine du domaine (ex. mondomaine.tld) redirige vers la langue par défaut (ex. mondomaine.tld/fr/).

Documentation sur la configuration des langues : https://wpml.org/fr/documentation-6/guide-de-demarrage-rapide/configuration-de-la-langue/#visitor_language

Langues ‹ MDL — WordPress.png

Modifier la page ‹ MDL — WordPress.png

Langues ‹ MDL — WordPress (1).png

This topic contains 13 replies, has 5 voices.

Last updated by Joy M-L 4 years, 9 months ago.

Assigned support staff: Pierre.

Author Posts
February 25, 2015 at 8:47 am #566407

francoisM-3

I am trying to: hidden link

I visited this URL: hidden link

I expected to see: hidden link

Instead, I got:

February 25, 2015 at 12:44 pm #566611

Pierre
Supporter

Languages: English (English ) French (Français ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Bonjour,

Merci de contacter le support de WPML !

J'ai constaté que vous aviez 3 langues actives sur votre site (en, fr, de) et que chaque langue est disponible et fonctionnel dans des sous-répertoires ('/en/', '/fr/', '/de/').

Je pense donc que vous êtes dans la configuration suivante : "Format d'URL de langue" = "Langues différentes dans les répertoires" et "Utiliser le répertoire pour la langue par défaut".

Cela signifie que vous devez définir ce que va afficher la page racine de votre site (hidden link). Pour cela, vous avez 2 options : soit créer manuellement une page HTML, soit utiliser l'éditeur de page de WordPress.

Est-ce que c'est bien ce que vous souhaitez faire ?

Je vous invite également à me fournir vos informations de déboggage que vous trouverez dans WPML > Assistance technique en cliquant sur le lien "page".

Cordialement,
Pierre

February 25, 2015 at 1:08 pm #566632

francoisM-3

Ceci est déjà fait, la page est déjà définie, et avant la mise à jour de WPML nous n'avions pas ce problème

February 25, 2015 at 1:44 pm #566664

Pierre
Supporter

Languages: English (English ) French (Français ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Dans un premier temps, je vous invite à mettre à jour WordPress à sa dernière version.

Ensuite, afin d'isoler le problème, est-ce que vous pourriez désactiver tous les plugins qui ne sont pas relatifs à WPML et vérifier que le message d'erreur est toujours présent ?

S'il n'y a toujours pas d'amélioration, je vous propose d'activer le thème parent (Avada) et d'effectuer à nouveau la vérification.

J'attend votre retour.

Cordialement,
Pierre

February 25, 2015 at 2:13 pm #566696

francoisM-3

J'ai procédé comme demandé, et le message d'erreur est toujours présent.
Je ne sais pas comment activer le thème AVADA, et j'ai peur du résultat
Vous pensez à remettre le thème initial AVADA, sans les personnalisations ?

February 25, 2015 at 2:20 pm #566703

francoisM-3

C'est encore pire, en remettant le thème AVADA de base

February 25, 2015 at 2:34 pm #566728

Pierre
Supporter

Languages: English (English ) French (Français ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Ce que je souhaite dans un premier temps, c'est d'isoler le problème mais je comprend votre appréhension concernant la perte de certaines personnalisations. Je vous propose donc de faire une sauvegarde complète de votre site. Pour cela, vous pouvez utiliser Duplicator (https://wordpress.org/plugins/duplicator/) qui est disponible sur le dépôt public de WordPress.

De ce que je comprend du message d'erreur, la page "spéciale" à afficher à la racine du site n'est pas retrouvée.

Afin de vous apporter une meilleure assistance, je vais vous demander un accès temporaire au site (wp-admin et FTP).

Vous trouverez ci-dessous des champs spécifiques à remplir pour me fournir les informations de connexion. Votre réponse sera privée, donc ces informations ne seront visbles que par vous et moi.

Préalablement, merci d'effectuer la sauvegarde de votre site.

Cordialement,
Pierre

February 25, 2015 at 4:49 pm #566840

Pierre
Supporter

Languages: English (English ) French (Français ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Je pense avoir trouvé le problème. Vous avez défini "Une page, Créer une page racine" pour "Ce qu'il faut afficher pour l'url racine" dans WPML > Langues (voir copie d'écran).

Or comme vous avez le lien "Créer une page racine", cela signifie que vous n'avez pas encore de page racine, d'où l'erreur.

Cette page racine est une page d'aiguillage qui est généralement utilisée pour présentée pour présenter les différentes options de langues sur le site. Cette page "spéciale" n'a d'ailleurs pas de langue définie et vous ne la verrez pas apparaître dans la liste des pages existantes.

Si vous souhaitez toujours utiliser cette option, il faut impérativement créer cette page en cliquant sur le lien "Créer une page racine".

Si vous souhaitez rediriger vers la langue par défaut hidden link, il n'y a pas d'option spécifique pour cela avec WPML. Cependant, je vous propose de tester la solution suivante :
1. Créer un template de page qui redirige vers la langue par défaut
2. Créer la "page racine" et sélectionner le template précédemment créé puis enregistrer

Voici le template de page que je vous propose:

<?php
/*
Template Name: Root redirect
*/
wp_redirect( home_url() );
exit;
?>

Placez ce code dans un fichier "page-root-redirect.php" que vous placerez à la racine de votre répertoire de thème enfant.

Merci de me dire si cela fonctionne et correspond à vos besoins.

Cordialement,
Pierre

PS : J'ai réactivé le thème enfant.

February 26, 2015 at 8:19 am #567145

francoisM-3

Bonjour,
Merci de votre aide et votre patience.
Jusqu'à présent le site à toujours fonctionné ainsi :
Dans les reglages, options de lecture, la premiere page à afficher était MDL Europe KNow How
Je ne m'occupe habituellemet pas du site et ne sais pas faire un template de page.

February 26, 2015 at 2:14 pm #567451

Pierre
Supporter

Languages: English (English ) French (Français ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Bonjour,

Concernant le réglage que vous mentionnez dans Réglages > Lecture, il s'agit de la page d'accueil ou "homepage" en anglais (une fois que la langue est définie). Or, la configuration actuelle fait que la page racine est différente de la page d'accueil.

Autre point, le réglage "www/en/" au-dessus de "une page" est erroné et ne peut pas fonctionner. Il s'agit de la définition d'un chemin d'accès vers un fichier HTML sur votre serveur, mais de toute façon ce n'est pas cette option qui est activée. Donc vous pouvez effeacer le contenu de ce champ.

J'ai ajouté le template de page et j'ai créé la page racine (voir les copies d'écran jointes).

A priori, cela fonctionne correctement. Pouvez-vous me confirmer?

Cordialement,
Pierre

February 27, 2015 at 8:00 am #567898

francoisM-3

C'est vraiment parfait comme cela !
Merci beaucoup

August 11, 2015 at 10:17 pm #677635

xavierB-6

Je suis vraiment étonné qu'on ait besoin de faire cette manipulation bizarre. Ca serait tellement plus simple que WPML redirige directement vers la langue par défaut (qui porterait mieux son nom, du coup) !

September 16, 2015 at 2:07 am #705050

mattT-5

Bonjour, j'ai ce même problème, j'ai site.fr/fr/ qui fonctionne ok, et site.fr/en/ aussi, mais site.fr non. Lorsque je tente d'accéder à site.fr, ça affiche ça :

Warning: include(/): failed to open stream: No such file or directory in /homepages/9/d409095811/htdocs/wp-content/plugins/sitepress-multilingual-cms/inc/request-handling/redirection/wpml-rootpage-redirect-by-subdir.class.php on line 49

Warning: include(): Failed opening '/' for inclusion (include_path='.:/usr/lib/php5.4') in /homepages/9/d409095811/htdocs/wp-content/plugins/sitepress-multilingual-cms/inc/request-handling/redirection/wpml-rootpage-redirect-by-subdir.class.php on line 49

J'ai créé la page 'page-root-redirect.php' avec le code suivant que j'ai mis à la racine du template :

<?php
/*
Template Name: Root redirect
*/
wp_redirect( home_url() );
exit;
?>

Mais par la suite votre message est, pour moi, inintelligible :

"Il faudra ensuite sléctionner l'option "Une page" pour "Ce qu'il faut afficher pour l'url racine :". Enfin cliquer sur "Créer la page racine".

Sélectionner l'option OnePage où ? Pour... What??! Puis cliquer où ?!

Dans l'éditeur de page de WordPress, il faudra sélectionner le modèle de page précédemment créé."

C'est trop imprécis pour moi. Pourriez-vous être plus clair ? Concernant le screenshot juste en dessous de ce texte que vous avez écrit, en haut à droite on voit qu'on peut ne pas sélectionner de langage, or quand je le fais, j'y suis contraint. Lorsque j'en sélectionne un, que je fais la manip telle que je l'ai comprise, j'ai site.fr/fr/ et site.fr/en/ qui ne fonctionnent plus.

November 25, 2017 at 3:41 am #1441000

Joy M-L

Bonjour,

Je pense être dans le même cas de figure. Avant de créer un nouveau topic, permettez-moi de vous exposer mon problème. Wpml est configuré sur mon site pour afficher les langues dans des répertoires différents. Le Français étant la langue par défaut. Or je me retrouve à avoir :

- Une page hidden link qui affiche correctement mon site.
- Une page hidden link qui affiche à peu-près la traduction de la page ci-dessus
mais comportant des bugs d'affichages et de liaisons entre les deux pages.
- Et enfin une page : hidden link , qui renvoi à une page erronée du site...

J'aimerai donc effectuer ce qui s'apparenterai à une redirection de la page native à la page /fr ( langue par défaut).

J'ai essayé de suivre vos conseils et actions mais rien n'y fait.

Ci-joint deux captures d'écran.

J'ai essayé de créer la page root-redirect ' cependant dans la colonne de droite ( Attributs de page ), je n'ai pas la mention suivante : ' root-redirect '. Voir le screenshot ci-après.

En vous remerciant pour votre lecture et je l'espère, votre aide.